4

At wit's end. Have MBP named newt running High Sierra. Have Windows 10 machine named "Vader" that's always up & running with a physical drive (X:) shared as //Vader/x with permissions set to Everyone having full control. Other Windows machines can access share just fine & read, write, etc. Windows 10 box has user Adams with no password & automatically logs in at boot.

Prior to installing Sierra, had no problems accessing share. Since Sierra (now on High Sierra, hoping it'd fix but didn't), I haven't been able to access at all, always with the following error with text There was a problem connecting to the server: enter image description here

Windows 10 machine's workgroup is WORKGROUP, and so is MBP's: enter image description here

Here's newt's DNS settings: enter image description here

I've got a pretty simple Google WiFi setup (with 3 units) providing my home network. All machines are on the wifi network (192.168.86.0/24). Here's some terminal output from newt:

$ ping vader
PING vader.lan (192.168.86.86): 56 data bytes
64 bytes from 192.168.86.86: icmp_seq=0 ttl=128 time=2.208 ms
64 bytes from 192.168.86.86: icmp_seq=1 ttl=128 time=5.940 ms
^C
--- vader.lan ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 2.208/4.074/5.940/1.866 ms
matthew@newt:/Volumes
$ smbutil lookup vader
Got response from 192.168.86.86
IP address of vader: 192.168.86.86
$ smbutil status 192.168.86.86
Using IP address of 192.168.86.86: 192.168.86.86
Workgroup: WORKGROUP
Server: VADER
$ smbutil identity -N //vader
smbutil: server connection failed: No such file or directory

Any help would be greatly appreciated. I don't know what else to try. I've searched many docs, forums, StackExchange sites, etc.

  • Have you tried connecting using the server's IP address? – IconDaemon Oct 17 '17 at 14:45
  • Yes. Same result. – Matthew Adams Oct 17 '17 at 14:49
  • I have the exact same problem. Driving me crazy. It all used to work perfectly until I updated the OSX. One sliver of hope is that I can connect my PC to my MBP. This means I can be on the PC and see the files on my MBP that are shared and make file transfers. However, while on the MBP, I can't connect to the PC, even though Finder shows it under "Shared" in the sidebar. Nothing has worked. Very frustrating. – Greg May 9 '18 at 10:59
  • 1
    Using Go>Connect to Server from the Finder menu was suggested to me to be the bulletproof method, but I get "The share does not exist on the server. Please check the share name, and then try again." I'm not sure how to interpret this. One thing Mac does really poorly is provide any plain language error messages. I too would really appreciate any help/ideas. – Greg May 9 '18 at 10:59
2

Ensure the Network Connection on your Windows 10 computer is configured to allow File and Printer Sharing:

Control Panel -> Network and Internet -> Network Connections. Right-click the Network you are using, click Properties, and ensure File and Printer Sharing for Microsoft Networks is selected.

2

For me the solution was to check if SMB server was active on windows pc (and it was not!!, just SMB client is active by default):

  • go in search field at the right of WINDOWS icon and type: WINDOWS FEATURES
  • scroll the list and find SMB support
  • make sure that SMB server is checked, if not check it and restart pc.

enter image description here

1

This worked for me. Go in to sharing preferences on your mac and make sure when you click on options its set to "share files and folders using SMB" and not AFP. Scroll down and check the box next to the account and it worked instantly.enter image description here

0

It sound silly.... but I had a big fight with my MAC/Win10 LAN. I tried everything I read and nothing worked....till I set a password in the windows (onlyuser-account without M$-addons and logins) computer.

After restarting, the PC appeared instantly on the Mac

0

Had the same issue connecting from a Mac to a Windows 7 Machine. It appears that this was related to a faulty Windows update released July 10th 2018 and then further corrected in another update on July 16th 2018.

It resurfaced for me because of a failed Windows update that blocked the autoupdate process.

Download and install KB4345459 manually from Microsoft Update Catalog to fix the issue.

-2

Go to the  Apple menu and choose ‘System Preferences‘ from the drop down menu. To enable File Sharing in macOS or Mac OS X, open the ‘Sharing‘ pane of ‘System Preferences‘ and select the option for ‘File Sharing‘. Windows computers and Macs can then see your computer on the local network. If you want to add an existing user for SMB file sharing open ‘Options…‘ for selecting and activating the user. For details see Apple’s support document.

  • The OP clearly asked about accessing a Windows share from their Mac, not sharing something from their Mac to Windows. – Stuart H Feb 15 '18 at 23:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .