2

I have connected my MacBook Pro to a Samsung P2770HD monitor using a Kanex brand Mini Displayport to HDMI cable

However, the output on the Samsung monitor is absolutely garbage. It is pixellated to the point that I don't even want to look at it.

The resolution is 1600x900 (but I have tried all other resolutions as well - all with similar output)

When I connect my Windows laptop to the same monitor using DVI cables, I get 1920 x 1080 resolution and the display is crystal clear.

How do troubleshoot this?

5
  • 2
    Have you tried mini-DP to DVI? The problem could be the HDMI interface, as opposed to your Mac. – Dan J Nov 5 '11 at 12:53
  • I concur with @djacobson. Try that and get back to us. – David Metcalfe Nov 5 '11 at 17:54
  • 1
    Also, have you tried a different HDMI cable? .. Alternatively, it could be an HDCP handshake problem on the monitor; try plugging in that same monitor into a DVD player with the same HDMI cable. – adamrmcd Nov 6 '11 at 3:39
  • @djacobson I only have one DVI input on the monitor and that has been taken up by the cable coming in from the PC. However, this calls for a trek to the Apple store - I will test to see if I can eliminate the HDMI interface as an issue. – Raj More Nov 6 '11 at 11:05
  • @adamrmcd I have tried with a different HDMI cable with the same issue (but that was from PC to HDMI). I will test the DVD player today as well. – Raj More Nov 6 '11 at 11:07
2

To fix, use the monitor's menu and change Size&Position/Image Size to Screen Fit.

(I connected a MacBook Pro 2013 via HDMI to the same monitor and the quality was horrible.)

1

There is a bug on the HDMI driver (or somewhere that is related to HDMI, DVI works just fine) that Apple hasn't fixed yet (Sep 2012). You can see the discussion here: https://discussions.apple.com/thread/4080525?start=195&tstart=0 Using the DVI connection fixes the problem (which unfortunately in your case is already taken).

1

I found that setting the Picture -> Mode to "Movie" helped it a little, but it is still atrocious.

1
  • thanks. looks way better with "movie" on my tv – samsamara Aug 27 '18 at 0:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .