79

I forgot to turn on "VNC viewers may control screen with password", to enter on my working Mac, is there way to turn-on this feature remotely via SSH (I'm on WindowsXP now)?

2 Answers 2

115

Source: http://technotes.twosmallcoins.com/?p=279 (archived)

Putty is a good SSH client for Windows.

  1. SSH into your remote OS X machine with an administrator’s log in and password.

  2. Enable Remote Desktop (a.k.a. Screen Sharing, a.k.a. VNC) with this command:

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart \
    -activate -configure -access -on \
    -clientopts -setvnclegacy -vnclegacy yes \
    -clientopts -setvncpw -vncpw mypasswd \
    -restart -agent -privs -all
    
  3. Login using a VNC client. As I mentioned, TightVNC worked for me; for some reason, RealVNC and UltraVNC didn’t. Your password is “mypasswd” (see the -vncpw flag in the above command; you can and should change this).

  4. When you are done, turn off screen-sharing using your SSH session:

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart \
    -deactivate -configure -access -off
    
16
  • 2
    Amazing! Works!
    – StNickolay
    Nov 4, 2011 at 22:43
  • 3
    3+ years later and works perfectly in Yosemite. Thanks!
    – Jordan
    Feb 22, 2015 at 2:19
  • 1
    Warning: this breaks with the "Remote Desktop Client Update v3.8.5" update. See here: discussions.apple.com/thread/7501620?start=15&tstart=0
    – shrx
    Mar 28, 2016 at 23:38
  • 1
    @Novellizator Both Mac and Linux have ssh available out of the box. No need for a separate package like you need on Windows. Jul 15, 2016 at 0:40
  • 6
    Warning: macos 10.14 and later only allows control if Screen Sharing is enabled through System Preferences.
    – grAPPfruit
    Feb 19, 2019 at 10:55
40

Here is a different way, that enables screen sharing access for all current users, instead of using a single VNC password:

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart \
 -activate -configure -access -on \
 -configure -allowAccessFor -allUsers \
 -configure -restart -agent -privs -all

Disable it with this:

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -deactivate -configure -access -off

This allows you to connect to the remote computer from a mac using the share screen button in Finder.

Reference: http://ss64.com/osx/kickstart.html

7
  • 2
    For posterity: if you do this, you can also connect via /System/Library/CoreServices/Screen Sharing.app.
    – Danica
    May 27, 2013 at 20:50
  • 1
    Note that you can (very) easily launch the Screen Sharing app using a Spotlight search Nov 7, 2016 at 22:05
  • 1
    worked for me on macOS High Sierra 10.13.6 Aug 20, 2018 at 7:10
  • 15
    Got this response on macOS Mojave: "Warning: macos 10.14 and later only allows control if Screen Sharing is enabled through System Preferences."
    – toralux
    Aug 15, 2019 at 8:26
  • 1
    Not working for me on 10.15.7. Once this command is run, you can connect with Screen Sharing, but the screen is black. By contrast, turning it on with the System Preferences app, you don't get that issue. Jun 30, 2021 at 8:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .