4

For the past few weeks my new iMac kept freezing. After many, many hours with Apple tech support, both in the store and on the phone, we narrowed it down to something called SafariBookmarksSyncAgent which is sucking up all my memory, putting the memory pressure into the red, then off the scale.

To use my computer, I have to keep the Activity Monitor up on the screen so I can force quit SafariBookmarksSyncAgent when it pops up every 3 to 5 seconds.

No one at tech support has been able to figure it out. We've tried safe mode, we've unchecked Safari (I use Firefox, not Safari as my browser) under iCloud in all devices in my house. The Apple tech people say they never even heard of SafariBookmarksSyncAgent. Right now, the engineering department is supposed to be looking into it.

How can I solve this issue?

1
  • Please let us know the version of macOS you are using and the model of your iMac.
    – oa-
    Oct 16, 2017 at 14:16

4 Answers 4

3

I found a solution that worked for me. It involved updating the permissions for my home directory, as indicated in the following article:

https://support.apple.com/en-us/HT203538

1
  • this seems to work on Mojave, but I wonder why is this happening :( Aug 28, 2019 at 14:42
0

Resetting user folder permissions didn't work for me. The process still consumed my CPU like crazy. Then I followed the steps explained here:

  1. In Safari on my Mac I exported my bookmarks. File -> Export Bookmarks.
  2. I turned off Safari iCloud Sync on the Mac and my devices.
  3. I deleted all Bookmarks from all devices and then properly closed Safari on all devices.
  4. Waited a few minutes.
  5. Turned on Safari in the iCloud cdev on the mac and my devices.
  6. Waited a few minutes and watched the processes for any long spikes.
  7. Imported my bookmarks from the backup file.

NOTE: Below part is NOT NEEDED. It's just running around the bush, no real solution to the problem, but could be useful for some. You can install a minutely cronjob to kill the process.

  1. Open terminal and run crontab -e
  2. Paste below line and save the file

*/1 * * * * /bin/bash -c "ps x| grep SafariBookmarksSyncAgent| grep -v grep| cut -d' ' -f 1| xargs kill -9"

1
  • wow - that's cool and unlikely that another process would have the same ** SafariBookmarksSyncAgent** string and get caught in the cross fire. Any reason you didn't use launch agent to just not start that process or another launch agent to kill it each time it launches?
    – bmike
    Oct 3, 2018 at 15:40
0

My solution was,

  1. Turn off Safari bookmark sync in iCloud settings on all devices.
  2. Backup your bookmarks in Safari (File -> Export Bookmarks)
  3. Delete all bookmarks on all devices.
  4. Turn on Safari bookmark sync.
  5. Wait 5 minutes.
  6. Import bookmarks, then you will see everything is going well.
0

reinstall of Safari has always fixed this when i find it on the ones that i support.

1
  • 6
    How do you reinstall Safari on macOS?
    – nohillside
    Mar 18, 2019 at 14:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .