Since yesterday, I'm having a problem with auto update from Opera. Until yesterday I had no problem.

I'm in OS X Mountain Lion 10.8.5, and the last supported version is Opera 37.0.2178.54. Now it automatically updates to 48.0.2685.39 and after I close Opera I cannot open Opera again because it tells me “This version is not supported, you need 10.9”.

In version 37, there is no preference setting to turn off autoupdate - you get it whether you want it or not.

How can I stop Opera from auto updating? I want to be in version 37, which is supported in my operating system.

  • I don't have that autoupdate option in version 37. – Manuel Oct 16 '17 at 11:58

Rename the autoupdate binary.

You should be able to find it in /Applications/Opera.app/Contents/MacOS

Rename it to anything else:

mv /Applications/Opera.app/Contents/MacOS/opera_autoupdate /Applications/Opera.app/Contents/MacOS/opera_autoupdate.bak

Technically speaking, you could delete it, but in my experience, it's always safer to rename (move) it to something else. This way, if something goes wrong, you can easily revert.

Disclaimer: I don't have the older version of Opera so I cannot personally test if it works on v37.x.xxxx.xx

  • It does work. I saw this for Windows, but didn't know where the binary was. – Manuel Oct 16 '17 at 13:15
  • or, as an alternative, you can remove the executable permission with chmod -x /Applications/Opera.app/Contents/MacOS/opera_autoupdate – ccpizza Oct 17 '18 at 20:32

Try the following steps:

  1. Completely uninstall all the versions of Opera from your Mac.

  2. Reinstall your preferred version of Opera.

  3. Disconnect from Internet connection.

  4. Launch and Quit Opera.

  5. Launch Terminal.

  6. Type this code and hit enter.

    defaults write com.operasoftware.Opera OPDisableAutoUpdate true
  7. Reconnect Internet, launch Opera, and select About Opera.

  8. The screen will display if auto update has been disabled. It should look something like this:

    Version information
    Version:    49.0.2725.64 - Update checker is disabled
    Update stream:  Stable
    System: Mac OS X 10.9.5 64-bit

For other Opera version, please try this:

  • Download version you want http://www.opera.com/download/index.dml/?os=mac&list=all
  • Turn off Wifi network
  • Delete current Opera App, delete 2 folders: ~/Library/Application Support/com.operasoftware.Opera; ~/Library/Caches/com.operasoftware.Opera
  • Re-install Opera and open it for the first time (keep Wifi off)
  • Delete auto_update in /Applications/Opera.app/Contents/Versions/49..../Opera Framework.framework/Helpers

  • Turn Wifi on and relaunch Opera, it will stuck when autoupdate

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .