3

I have a rMBP (late 2012 model) that I recently installed High Sierra on and enabled FileVault (this has apparently been known to cause some similar issues on older version of OSX, but I found no work around with High Sierra).

Currently when I try to log into my standard user on boot up, I get a progress bar that get to ~75% progress and then freezes (I have left it in this state overnight with the hopes that it was just slow - no luck).

Restarting the computer in recovery mode (cmd+R) causes a similar issue, where the progress bar gets to about 50% and then freezes (again I've let it sit here overnight with no progress), meaning I cant use the disk utility to repair the disk.

Safe mode (shift on startup) also doesn't do anything - progress bar freezes at ~75% on logging in.

Resetting the PRAM and SMC also don't appear to do anything.

Booting in single user mode (cmd+S) lets me attempt to repair the disk manually using:

/sbin/fsck -fy/

But it repeatedly returns the error:

warning: apfs_keylocker.pr_block_count is zero for encrypted fs (0x403)
** The volume /dev/rdisk1s1 could not be verified completely.
apfs_vfstop_unmount:1405: fake mount <ptr> going away

Running verbose mode (cmd+V) on startup runs until it reaches:

en3: promiscuous mode succeeded
IOConsoleUsers: time(0) 0->0, lin 0,lik 1,
IOConsoleUsers: gIOLockState 3, hs 0, bs 0, now 0, sm 0x0
Setting BTCoex Config: enable_2G:1, profile_2g:0, enable_5g:1, profile_5g:0

Where it locks up and freezes.

I have also tried reinstalling OSX from a bootable USB drive and via WiFi. In the case of the USB installer, the progress bar, once again, gets to ~75% and freezes. Using the WiFi method, I get a grey screen to appear with a pinwheel that spins for about 3 seconds before freezing and crashing.

From reading various forum posts, it seems like either my harddrive has finally died or FileVault and High Sierra aren't playing nice together. Ideally there is some work around that I've missed, but I do have backups, so I'm okay with wiping the harddrive completely, but as of now, I don't even see a way of doing that.

Any/all advice or input is appreciated and thanks in advance for any help!

  • fsck can run only after having successfully decrypted the volume. Without this correct run of a fsck there isn’t any evidence your FS or your disk are damaged. – daniel Azuelos May 13 '18 at 8:12
  • Did you find a way to fix this problem? – daniel Azuelos May 17 '18 at 10:12
  • same problem -- any solution? – neuralstatic May 31 '18 at 0:05
-1

I guess your disk is corrupted very badly the only way to format your disk is to ask a friend to give their Mac to you and buy a thunderbolt To Thunderbolt port and then connect these to your friend's and your Mac and then restart your broken Mac in Target display mode by following this guide:Erase MacBook hard drive without OSX disc

  • Yeah, I was planning on trying that as a last resort but was hoping there was another way. Oh well... Thanks again for all your help! – nibbs93 Oct 17 '17 at 5:20
0

I upgraded to High Sierra (iMac 27″ late 2013). I worked without problems for 5 days. Then the disaster: progress bar that gets to ~75% progress slowly (very very slowly) and then freezes.

I tried:

  • restart in safety Mode
  • reset PRAM
  • check HD with Disk Utility (no problems detected)
  • restart in recovery Mode and reinstall High Sierra from partition

but there was the same problem (progress bar that gets to ~75% progress and then freezes)

Yesterday I boot my iMac from an external HD (with Sierra OS) and now I'm working with this (I reinstalled only Adobe Suite).

I think that the solution is reinstall Sierra.

You must log in to answer this question.

protected by Community Dec 7 '17 at 10:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .