3

I have a 5 TB Seagate external drive connected to a 2012 MacBook Pro (non Retina) through a USB-3 connector that always gets ejected while I am copying files to it. When I try to copy large amounts of data to it, I get the message Drive was not ejected properly after about 20 to 30 seconds. I have macOS Sierra installed on that MacBook Pro. Before, I was using this drive with a 2011 MBP with OS X Yosemite, and it did not have that problem.

I have googled this issue, but all I find is posts from people complaining that their drive gets ejected when their Mac goes to sleep, which is not the case here. I can leave my drive connected to my MBP for hours, and it won't get ejected unexpectedly unless I copy files to it.

Anyone else has had that problem? Did you find a solution?

UPDATE:

It happens on both USB ports, and it does not happen if I use another drive of different brand with the same USB cable.

I also tried the copying files from a MacBook Air running El Capitan to the Seagate drive, and there was no problem.

If I connect the Seagate drive to a docking station that is connected through a Thunderbolt cable to my MBP, then there is no problem copying the files.

UPDATE 2:

I booted my MBP from an external drive with Yosemite on it, and I tried copying large files to the Seagate USB drive again. There was not problem. So the problem seems to be related to macOS Sierra.

  • Have you tried a script to copy the files in "chunks" instead of all at once? – Solar Mike Oct 14 '17 at 22:51
  • @SolarMike what's the idea behind that? Even if we then knew the problem was the disk soft-crashing when it's written too quickly then what? – Sirens Oct 14 '17 at 23:13
  • @SolarMike No, I haven't tried that, but it would not solve my problem. I want to be able to use that disk normally. I as gonna use it with Data Rescue to save files rescued from another disk, but I could not. The disk always got ejected after a minute or two. Then I tried moving files from another disk to that disk to make space on that other disk, but the result was the same. – Jean-François Beauchamp Oct 14 '17 at 23:55
  • Sounds like a hardware/cable issue. Does the Seagate have a detachable cable, or is it fixed? If you wiggle the cable, or move the drive, does is dismount spontaneously? If the cable is detachable, get another cable and see what happens. Have you tried all the USB ports on the MBP? – IconDaemon Oct 15 '17 at 0:08
  • @IconDaemon Yes, the Seagate HD has a detachable cable. I tried both MBP USB-3 ports, and the result is the same. The HD has its own power supply. I did some more tests, and in fact, it happens quicker than I thought. It takes only around 20 seconds for the drive to be ejected. Copying files in the other direction, from the external drive to the MBP that is, is not a problem. I attached another HD to the same USB-3 cable and I was able to copy a whole folder on it. The same operation fails on the Seagate drive. – Jean-François Beauchamp Oct 15 '17 at 0:41

You must log in to answer this question.

Browse other questions tagged .