I installed Mac OS X lion on an SSD (through USB) after checking the firmware was the latest version (2.15). When I transferred the SSD into the MacBook Pro (like i usually do after an install) but it displayed a folder with a question mark during boot.

Upon rebooting and entering the boot menu there were no drives displaying. I restarted a few times after checking the cables and connectors but to no avail.

When starting from an USB boot drive the computer is extremely slow and the SSD apears to be sometimes missing in disk utility.

When it is present Disk utility fails to run any diagnostic.

I tried resetting the pram/nvram and Smc. No improvements.

When the SSD is installed in a Mac Mini it runs fine I can even boot to the system ant it runs blazing fast.

Is there something I can do to get it running?

I bought this SSD to replace my current hard drive which is behaving suspiciously, and now I am stuck between 2 problems.

  • Given your installation steps, reseating the SSD would be my first try. – David Metcalfe Nov 5 '11 at 0:05
  • Tried that no luck. – Coyote Nov 9 '11 at 15:54

After a lot of pain and testing the SSD works fine, but not in my Macbook Pro 5,1 (late 2008). After looking for an answer and pointers on the net I found the case of this unanswered post and this user with an Agility 3 120Gb not working either.

I'm returning it.

  • IF you purchase a different SSD, please feel free to let us know if the issue is rectified. – David Metcalfe Nov 9 '11 at 21:48
  • Sure in a few weeks... – Coyote Nov 10 '11 at 0:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .