When I type

brew install emacs

at the Terminal, the following message displays:

Warning: emacs 25.3 is already installed

However, when I type

emacs &

the only thing that happens is that the following message is displayed:

[1] 21302

but the Emacs GUI isn't launched. I have another apple computer where typing

emacs &

launches the Emacs GUI. How can I make the Emacs GUI launch by executing a command from the Terminal?

macOS Sierra Version 10.12.6

  • What is the result of type emacs on both systems? Is .emacs the same? – nohillside Oct 13 '17 at 14:47
  • 1
    @patrix: The result is emacs is /usr/local/bin/emacs on both systems. – Evan Aad Oct 13 '17 at 14:54
  • 1
    @patrix: .emacs is the same: I've just copied it from the "well-behaved" computer to the "troublesome" computer. – Evan Aad Oct 13 '17 at 14:57
  • What happens if you start emacs in the foreground? Any error messages or such? – nohillside Oct 14 '17 at 7:54
  • @patrix: Emacs starts inside the Terminal window as a console application. – Evan Aad Oct 14 '17 at 9:11

The installation command should end with the option --with-cocoa:

brew install emacs --with-cocoa

But first execute

brew uninstall emacs

or else Homebrew will refuse to reinstall Emacs.

As an alternative to brew install emacs --with-cocoa, Homebrew recommends running

brew cask install emacs

(you get this recommendation in the end of the brew install emacs --with-cocoa run). However, I've found that this doesn't work, and ends with the following error message:

Error: It seems there is already an App at '/Applications/Emacs.app'.


This answer is essentially copied from here.

Update as of July 23 2019: The --with-cocoa option is not supported any longer. Follow these steps.

  1. brew uninstall emacs
  2. rm -rf /Applications/Emacs.app/z
  3. brew cask install emacs

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .