2

I am trying to copy some files via command line to the icloud drive

This is I have done:

cd '/Users/antkong/Library/Mobile Documents/com~apple~CloudDocs'
cp -r ~/Download .

Then I got a lot of 'No such file or directory' error messages. Here are some of them:

cp: ./Downloads/python-docs-samples-master/translate: No such file or directory
cp: /Users/antkong/Downloads/python-docs-samples-master/translate: unable to copy extended attributes to ./Downloads/python-docs-samples-master/translate: No such file or directory
cp: ./Downloads/python-docs-samples-master/translate/cloud-client: No such file or directory
cp: /Users/antkong/Downloads/python-docs-samples-master/translate/cloud-client: unable to copy extended attributes to ./Downloads/python-docs-samples-master/translate/cloud-client: No such file or directory
cp: ./Downloads/python-docs-samples-master/translate/cloud-client/quickstart.py: No such file or directory
cp: ./Downloads/python-docs-samples-master/translate/cloud-client/quickstart_test.py: No such file or directory

I have double-checked and I am certain the local files exist.

In console, I set the filter to 'icloud' and I see these logs:

default 12:07:57.409443 +1100   com.apple.iCloudHelper  MacOS error: -67050
default 12:08:02.507858 +1100   com.apple.iCloudHelper  MacOS error: -67050
default 12:08:07.757674 +1100   com.apple.iCloudHelper  MacOS error: -67050
default 12:08:12.858678 +1100   com.apple.iCloudHelper  MacOS error: -67050
default 12:08:18.105600 +1100   com.apple.iCloudHelper  MacOS error: -67050
default 12:08:23.300585 +1100   com.apple.iCloudHelper  MacOS error: -67050
default 12:08:28.403153 +1100   com.apple.iCloudHelper  MacOS error: -67050
default 12:08:33.548442 +1100   com.apple.iCloudHelper  MacOS error: -67050

Why the copying has failed?

1

The root cause of the issue is the lack of the disk space.

During my copy operation, my local HD has run out of spare space:

 df -h
Filesystem      Size   Used  Avail Capacity  iused      ifree %iused  Mounted on
/dev/disk1     233Gi  233Gi    0Bi   100%  5751980 4289215299    0%   /
devfs          191Ki  191Ki    0Bi   100%      661          0  100%   /dev
map -hosts       0Bi    0Bi    0Bi   100%        0          0  100%   /net
map auto_home    0Bi    0Bi    0Bi   100%        0          0  100%   /home
/dev/disk2s2   466Gi  420Gi   46Gi    91% 10491127 4284476152    0%   /Volumes/Time Machine

After I removed some apps from /Application and rerun the cp command, it works as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .