2

Is there a way for me to recover all of my data from an encrypted SSD? MacOS Sierra, MBP early 2013, 16 GB RAM, 768 GB SSD, 2.8 GHz.

My computer went black screen due to another problem with my graphics card. I have managed to boot to recovery usb drive using a combination of closing the screen and then pulling out the external monitor cable and then my intel graph card would start up and I would see recovery terminal on my screen.

I have basically followed how to decrypt the drive from Section 4. Steps 5-9 at a Stellar Info Blog Post highlighted in pink.

My drive was locked so being a noob I tried to unlock and found this website url and followed without reading further that it will incur data loss decrypting the drive.

I went to the terminal and typed diskutil cs delete and put in the UID of my boot drive, thinking it would unlock and decrypt my drive, but instead I was shocked to see that boot drive MacintoshHD got deleted or formatted. Now I have the name of that drive “APPLE SSD SM768 Media” as physical disk and volume underneath called “Untitled”. I have run once since then first aid, and I thought that first aid was in regards to writing to this drive (I now know that it fixes permissions).

I have no current backup of my documents and projects, photos and other important stuff. This makes me really worried. Since then I have been reading all sorts of info trying to learn what to do and am still not sure where to go and what to do.

Currently, I have installed OSX on the MicroSD card and currently running Sierra from there. I have scanned drive with few different softwares and I think I made an image copy of my Untitled volume. but not entirely sure if it is a good copy.

I found this link which looked promising, Recover deleted Encrypted OS X Extended volume this guy had luck to get his drive back, but this sounds very complicated to me since there is no more room for mistakes. What do you think should I attempt to do this on the original disk, or try on the clone that I have made? I will try clone today and then create another clone of that goes wrong I suppose.

I would be very grateful if anyone would be kind enough to help me resolve this or anyone else with equal knowledge in order to guide me.

Output from Diskutil list

disk 0 - original disk that needs restoring
disk 1 OSX-SD current os from the sd card
disk 2 - logical volume
disk 3 - my external seagate 1TB drive that I make a clone of the original losta data SSD



diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *751.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Untitled                750.4 GB   disk0s2

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *127.9 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage OSX-SD                  127.0 GB   disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3

/dev/disk2 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS OSSD                   +126.6 GB   disk2
                                 Logical Volume on disk1s2
                                 39AD8C4C-C888-4AC6-9044-4A1A9A850CB9
                                 Unencrypted

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Untitled                750.4 GB   disk3s2

===============
this is what I get when I do sudo gpt -r show /dev/disk0
Password:
       start        size  index  contents
           0           1         PMBR
           1           1         Pri GPT header
           2          32         Pri GPT table
          34           6         
          40      409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      409640  1465660376      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  1466070016     1269763         
  1467339779          32         Sec GPT table
  1467339811           1         Sec GPT header

Please let me know if you need any further info.

  • If you completely formatted the drive, it is very troublesome to retreive data, as SSD storage works by mapping everything into one file, then when it is erased, the file is just rewritten as a blank one. It is very costly to retreive data, and it is reccomended that you seek a professional in your area if the data is vital. — All the best. – bret7600 Oct 12 '17 at 0:40
  • Thanks for your input bret7600! any recommendation on affordable company in London? – borisio Oct 12 '17 at 9:03

You must log in to answer this question.

Browse other questions tagged .