1

Today, the WD Drive Utilities app on macOS started crashing on launch. This is very strange, since it was working fine as of yesterday.

I have three versions of the app: v2.0.4.9 (preinstalled on WD My Passport 2TB), v2.1.0.104 (preinstalled on WD My Passport SSD 1TB), and v2.1.0.166 (latest version from Western Digital support site). I've tried installing each version, and I'm experiencing the same crash-on-launch behavior with all three.

Also, I'm using macOS 10.12.6 (Sierra) and haven't yet installed macOS 10.13 (High Sierra), so I know that it's not due to an OS update.

I've uploaded a copy of the crash log to Pastebin; please check that. (The crash log is for v2.1.0.166 - let me know if it'd be helpful to share crash logs from the other versions as well.)

Does anyone have any idea what's causing this and any possible solutions? Please let me know! Thanks.

EDIT: I've now noticed that the app (specifically v2.1.0.166) works fine when no external drives are connected (all of my externals are WD drives, in case that makes a difference). If a drive is plugged in before or after the app is launched, the app crashes. I know that this is definitely a factor, but I have no idea how to fix it. Does anyone have any ideas?

  • Here is fine - as is SU... but please pick just one & don't cross-post ;-) – Tetsujin Oct 11 '17 at 19:02
  • Oops. I've already cross-posted, since I was hoping to get an answer as quickly as possible. Sorry about that! Based on where I'd be more likely to get a quick and reliable answer, should I delete the question here or the one on SU? – 1dareu2mov3 Oct 11 '17 at 19:04
  • 1
    I noticed, hence my comment ;-) tbh, idk which is likely to be quicker. many people just pass through once a day, so the entire SE structure isn't really time-sensitive; think days rather than hours. – Tetsujin Oct 11 '17 at 19:07
  • 1
    Okay. Thanks for the advice. I think that I'll delete the question on SU, since I'm experiencing the crashes on specifically on macOS (I haven't even tried other versions of the app, since I don't have access to any non-macOS computers). Plus, I feel like it might help that I've had more activity here than on SU - maybe people will be more inclined to answer, but I'm not sure. – 1dareu2mov3 Oct 11 '17 at 19:13
  • idk & I can't test, as I don't have any WD drives, but possibly clearing the saved state may help - see apple.stackexchange.com/questions/231207/… for a rather generic clear on an unrelated app, as a hint to try find it – Tetsujin Oct 11 '17 at 19:16

You must log in to answer this question.

Browse other questions tagged .