1

I have a 2012 mac mini I'm setting up. I've connected it to a new dell monitor I bought for it. I plug in the usb mouse and can get the pointer to move, but the click doesn't work. Any advice? I've read other posts and thought maybe it was my nearby imac keyboard or wireless mouse interfering, but I've turned them off & taken batteries out and still no click action.

Any other suggestions for what I might try or what might be wrong? I used a windows keyboard to login successfully, but still need a mouse to get into mouse/bluetooth settings in Control Panel. I'm trapped!

Thanks!

  • Have you tried the mouse on another machine? Can you feel the mouse click? Maybe mouse is malfunctioning. – jmh Oct 11 '17 at 18:25
  • Thanks. I have tried the mouse on another machine and it works fine. I've also tried using different mouse, but still no luck. – Llamabro3000 Oct 11 '17 at 19:16
  • is this an Apple mouse? Was the other machine a Mac as well? – jmh Oct 11 '17 at 21:45
  • Yes. I bought a wired usb apple mouse after failing with a regular pc mouse. I tested it with my macbook air and it worked fine. Puzzling. – Llamabro3000 Oct 11 '17 at 23:01
  • Have you tried adjusting any of the parameters in the System Preferences? – jmh Oct 12 '17 at 1:02

You must log in to answer this question.

Browse other questions tagged .