1

I have an external drive which is only recognised running diskutil list in Terminal, not in the GUI version or Finder:

/dev/disk1 (external, physical):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *500.1 GB   disk1
1:                        EFI EFI                     209.7 MB   disk1s1
2:                  Apple_HFS Backup                  250.0 GB   disk1s2
3:       Microsoft Basic Data XHDD                    249.6 GB   disk1s3

I have tried the following:

diskutil verifyDisk disk1

Problems were found with the partition map which might prevent booting Error: -69808: Some information was unavailable during an internal lookup

diskutil verifyVolume disk1sn
diskutil repairVolume disk1sn

Error starting file system verification for (bad disk ref): Disk object invalid or unable to serialize (-69810)

diskutil repairDisk disk1

Problems were encountered during repair of the partition map Error: -69808: Some information was unavailable during an internal lookup

diskutil eraseDisk JHFS+ Untitled disk1

Error: -69888: Couldn't unmount disk
or:
Error: -69877: Couldn't open device

For the first error I did subsequently:

diskutil unmountDisk force disk1

Which most of the time was sucessful. If not, I even tried to find processes that interfered with the drive (found here: stackex/os-x-cant-unmount-disk)

sudo lsof|grep disk1

Which did not find any processes.

In fact, now i can't even get to the unmountable part and alwas get the:

Error: -69877: Couldn't open device

Is this thing really done or is there more to do here?

  • If it is not in the GUI or finder, then it is not mounted - which is why you can't unmount it and that function is greyed out... – Solar Mike Oct 11 '17 at 11:30
  • Good to know, but mounting it just says that is not possible. And still: The erase verb wants me to have it unmounted anyway but still does not work. – lthz Oct 11 '17 at 12:04
2

When the command line cannot erase the disk, it’s time to reseat and replace all cables or take that drive to another Mac to eliminate a hardware failure.

You are using the correct erase syntax so this is major macOS side failure (unlikely but certainly possible) or hardware failure (likely).

  • 1
    Okay, I will try, maybe also with a Windows machine. Will report back. – lthz Oct 11 '17 at 12:25
0

I find when I run in to these problems I use Linux to reformat the disk because sometimes the disk is so messed up even windows won’t be able to do anything.

  • What would you do in Linux? I mean, do I not effectively invoke the same commands when using diskutil in the OSX command line? – lthz Oct 11 '17 at 12:58
  • @lthz yes but sometimes there are restrictions in OS X and in Linux there is a better GUI disk utility – nicco swanson Oct 11 '17 at 13:17
  • I've tried other OS for some edge cases - sometimes an oddball driver or flakey cable likes one chipset or timing of commands over the other. In theory - it shouldn't matter. In practice, sometimes it does. – bmike Oct 11 '17 at 15:43
0

It turns out I had to run diskutil erase as superuser

sudo diskutil eraseDisk JHFS+ DISKNAME disk1

In order to access the volume. this might have to to with the EFI boot partition still in place on the disk.

At least this worked after having erased anything but the EFI on a windows machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .