I often get the dialog box warning me that I'm opening an application for the first time. But, it isn't the first time. Some of these are applications that I use daily. enter image description here

I seem to be getting more of these after an OS upgrade, almost as if some database got reset. Can I do something to get these warnings to be generated properly?

up vote 37 down vote accepted

This warning pops up every time an application wants to register a URI handler (a something:// protocol). Normally, your approval is saved by LaunchServices, but that database can become corrupted. Try resetting it by doing a

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -all local,system,user

in Terminal. The warnings should pop up once for each application again after that, then be gone for good. If they keep coming, something is resetting the database on its own (a clue would be that the default browser / mail app / RSS app / FTP app you set keep resetting to the Apple provided ones).

  • Awesome answer. Have you found items like system preference panes getting this message more often in 10.7.2? – bmike Nov 4 '11 at 18:13
  • @bmike: not at all – which is why I think OP’s LaunchServices DB is (was) either corrupted, or something resets it. – kopischke Nov 4 '11 at 19:14
  • Thank you. I'm seeing some specific apps like ScreenSync never get the quarantine bit cleared in 10.7.2. Even if I rebuild the launch services database with your command, it still prompts me each time I log in (and it starts itself). I have had to resort to using xattr to manually delete the quarantine bits.... – bmike Nov 4 '11 at 19:22
  • @bmike: the quarantine bit triggers another warning dialog, the “This application has been downloaded from the internet (yadda, yadda)” one.That has nothing to do with LaunchServices. – kopischke Nov 4 '11 at 19:33
  • Now I'm confused. I get the same dialog on the pref pane that needs a quarantine bit to be cleared by hand. cl.ly/BZKm Is the difference the wording at the bottom of the dialog - one mentioning a web page and the other a location of the app? – bmike Nov 4 '11 at 20:51

I had the same problem (only with SourceTree, after an update), and seeing @kopischke's answer reminded me of another Ask Different thread, on another LaunchServices database problem:

Why does my Mac's list of "Open with" applications start listing the apps twice and sometimes three times?

The LaunchServices reset command provided there is slightly different from the one @kopischke provided:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

I tried that, and it solved my "Opening application for the first time" problem. But it did not require me to re-okay every other application as well (only a few; I didn't see an obvious pattern in which). So it may be worth trying this before trying the earlier suggestion.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.