40

My MacBook Pro will not play sound when I connect a second monitor via HDMI. When I use the volume buttons, I see this icon:

enter image description here

How do I resolve this?

7 Answers 7

37

macOS is outputting sound over HDMI and has decided that volume should only be changed on the device receiving the sound. If you want the audio to come out of the monitor, adjust its volume directly (or connect speakers). Otherwise, use either the Volume item in the menu bar (the speaker icon) or the Sound system preference to change your audio output device to "Internal Speakers".

sound pref for getting the output sound to the right devoice.

1
  • 1
    this does not work for me. it ignores this request. even though the menu says that sound IS coming out of my MBP! screenshot: share.getcloudapp.com/7KumxYeb
    – Arturino
    Jun 11, 2020 at 21:26
12

Try to open System Preferences -> Open Sound -> Click Output -> Switch devices to headphones or speaker.

4

I think your TV is playing the sound to change this go to Audio MIDI Setuo located in Applications>Utilities then click on the built in output and click on the settings gear located below the speakers then click 'Use this device for sound output'

1
  • 1
    This was the answer that helped me! Apr 18, 2019 at 16:36
3

Try running the following command:

sudo killall coreaudiod

and then restart coreaudiod like this:

sudo -u _coreaudiod /usr/sbin/coreaudiod &

This will kill the Core Audio daemon (which is a system-level process, so escalating your privileges to super-user levels using sudo is necessary.)

2
  • Maybe if there was another problem that resulted in the same symptom, but to be clear, I think's OP's perceived 'trouble' is with the HDMI connection as I have seen as well, and not really a bug, so I think the other 2 answers are better for this situation. This action may 'reset' the audio system, thus implicitly changing the audio device, but is a more destructive action, and usually unneecessary.
    – Pysis
    Oct 10, 2017 at 14:02
  • Fair enough for your reply, however, when i have had this issue in the past the command has always worked for me. Also a pretty common solution for others who have had this issue if you google around. Either way its up to OP to decide :)
    – 4Maes
    Oct 10, 2017 at 14:20
1

I fix from Sound setting from System Preference and it works: - Go to System Preference - Go to Sound - Select Internal Speaker Type Built In

Thanks

0

I just fixed this by going into the audio midi setup. - Click the + symbol on the bottom of the window. - select create Multi-Output Device. - highlight newly added device - click gears icon on bottom of window - select use this device for sound output.

It was absolute dumb luck messing with settings but it works!

1
  • 1
    Created the multi audio device. Media buttons F11 (less) F12 (louder) still don't work
    – BlkPengu
    Aug 16, 2018 at 17:27
0

I've got a 2017 MacBook Pro and recently bought a Dell U2719DC. I bought it because of the single USB-C cable into my MBP idea. Looking into how to control sound from the monitor, I tried the SoundFlower/Bed and although it did work, I found it to be a really ugly solution.

I was able to keep my 1-cable dream alive through buying an M-Audio Micro DAC for $60AUD (you can get much, much cheaper USB DAC's). It's just a USB based line out device that plugs into my monitors hub at the back, and gives me control over the output level without the need for any sketchy drivers or software - just plug it in and you're done.

This solution is probably not for everyone, and particularly limited to those with USB-C monitors, but I thought I'd share anyway.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .