2

When I do my workout in the morning I don't want to get any notifications. I put the watch on Do Not Disturb, Silent, and Theater Mode.

This silences all notifications from my phone ...

Except, at some point during my workout it vibrates me letting me know I've closed my daily activity goal and then again that I've closed my daily workout goal.

This seems like a bug.

I don't want to to turn off those notifications completely. I simply don't want them when I've told the watch not to disturb me.

1

I'm not 100% sure what you want to do can be done via the Do Not Disturb function, but the place to check is within the Watch app on your iPhone.

Do Not Disturb

  1. On your iPhone launch the Watch app
  2. Swipe up and tap on General
  3. Tap on Do Not Disturb
  4. Now make sure you enable the Workout Do Not Disturb option
  5. If it's not already, you may also want to try disabling the Mirror iPhone option

If the above doesn't work, then try manually disabling Activity Notifications as required (see below).

Activity Notifications

Before your morning workout:

  1. Launch the Watch app on your iPhone
  2. Tap on Notifications
  3. Tap on Activity
  4. Disable the Goal Completions option
  5. Disable anything else you may want to

I think this should work, but then you'll need to remember to enable it again after your workout. Of course, you could just keep it disabled and use one of the Activity complications to monitor the status of your rings throughout the day.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .