26

I recently updated to macOS High Sierra recently and noticed that sometimes there is a red bar/background over the right side of the menu bar, near time and Siri icons. This happens only on the secondary displays and also not on all workspaces.

enter image description here

It goes away if I make an app full screen and back to normal. I noticed this a few times on Sierra also but that was very rare and the bar used to be white instead of red. Is this a bug in Metal/Metal 2?

PS: The secondary display is connected via VGA.

  • I've also seen this issue a few times on High Sierra – bouke Oct 9 '17 at 12:54
  • 2
    Sorry - this should be a comment, not an answer. I also have this on High Sierra, but it happens on the main display, not secondary. Making an app full screen and then back to normal is my solution also. iMac (Retina 5K, 27-inch, Late 2015) – alphi Oct 12 '17 at 22:26
  • I've noticed this behavior on a lot of Macs of my colleagues now. Didn't find a proper fix till now. – Basant Singh Oct 18 '17 at 5:07
  • This problem seems to have been around for a while as you can see here. I'm having it on Sierra. It only happens on empty desktops on secondary displays. Opening and closing a Finder window is resolving it so far for me. – jan Nov 9 '17 at 3:32
  • I updated my retina iMac to High Sierra this week and today saw the red bar on the primary screen for the first time, when I created and switched to a new user. There is a low resolution secondary screen attached but I have not seen the red bar there. – emrys57 Nov 16 '17 at 9:12
17

I was experiencing this behavior on a secondary display as well. Although it is merely a workaround, I can confirm that putting an app in Full Screen mode on the secondary display will force the OS to redraw the menu bar.

  • 1
    yeah this works, but i face this multiple times in a day. It's becoming annoying now :/ – Basant Singh Dec 20 '17 at 6:23
  • Thank you, Youtube. Even though you're just playing music, you can still go full screen with the still image. :) Wow, that's a weird bug that was alarming at first. If there was an errant color on the screen, red is a bad choice. – macetw Mar 12 '18 at 13:28
1

First do a reboot and if that does not work try the following:

  1. Reset NVRAM/PRAM. http://support.apple.com/kb/PH18761 (Should resolve the issue)

  2. Reset SMC. Choose the method for “If the battery is non-removable”.

    https://support.apple.com/en-us/HT201295

  3. Start up in Safe Mode. https://support.apple.com/kb/PH21875?locale=en_US

    Once in Safe Mode, click the “Restart” button at the bottom.

  • 1
    This actually fixed the issue. I think the first step is enough for most cases. Thanks! – Basant Singh Feb 23 '18 at 8:25
  • UPDATE: Didn't fix. Still facing the issue – Basant Singh Feb 26 '18 at 5:16
  • Basant if you create an all new user on your laptop and then login as that user do you still experience the issue? I'm assuming you have all the latest OSX updates as of now correct? Of the above steps did you try steps 2 and 3? What year / model is your computer? – chainwork Feb 27 '18 at 5:59
  • Haven't tried with a new user, it's my work laptop, not sure if it's possible. I tried all 3 options. I'm using the MacBook Pro 2016 with TouchBar. I have all the latest updates. Running macOS 10.13.3 – Basant Singh Feb 27 '18 at 6:04
  • 1
    Do you have AppleCare? If you do you can try communicating with their support by phone or chat to see what fixes they might offer you. Or you can take it into the genius bar for an apt same day or made online at a date of your choosing. Another option may be to run time machine and backup your laptop, then reinstall your OS, test, then restore your user, test again. – chainwork Feb 27 '18 at 18:20
1

This also happens to me, and I've tried different displays connected via hdmi to hdmi, and i've also tried thunderport to hdmi.

A temporary solution that worked for me is just switching around the screen positions in settings > display > arrangement.

You can try that if the other answers don't work.

0

FIXED!! Seems like the issue has been fixed in macOS 10.13.4. I haven't faced the red menu bar since the update.

Maybe Apple has fixed the issue.

  • 1
    I assume you mean 10.13.4. – nekomatic May 23 '18 at 12:01

You must log in to answer this question.

protected by Community Oct 19 '17 at 18:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .