2

Back when High Sierra RC was released I thought I'd update since we have access to a developer account here at work.

I downloaded a tool from developer.apple.com to register my MacBook Pro for RC access but the application said beta, and even though I enabled "beta" access it didn't really give me the option to install RC.

So I promptly forgot about it, waiting for the full normal release instead, which then happened.

However, when I read about a recent fix to a security snafu regarding encrypted volumes and checked which version I was running I was surprised to find that my OS X had installed 10.13.1 Beta through App Store for me a couple of days back.

Having had some bad experiences with the beta versions of OS X earlier I wanted to go back to stock High Sierra.

I tried booting into recovery mode, but reinstalling from here wanted to use Beta. I tried downloading High Sierra from the app store and creating a bootable USB drive from it, but booting from it gave me the dreaded "stop sign" - https://forums.macrumors.com/threads/when-booting-from-usb-i-get-circle-with-line-through-it.1411034/ - and couldn't find a way to fix this, tried different USB pens as well.

However, something does seem to have worked. What I did was this. I found the version of High Sierra I had downloaded from the app store a little earlier and started it, asking it to install itself on my MacBook Pro, which it then did.

The machine boots back up after installation completes and now says Version 10.13, not 10.13.1.

So it seems it was successful in installing stock High Sierra.

However, I also seem to recall that the App Store update blurb with the 10.13.1 beta said I could not go back, which clearly I just did. Or did I?

So do I now have a hybrid beta/RTM version? That I really shouldn't go forward with?

Basically, now that I have tricked the recovery partition to be RTM instead of Beta should I do a fresh reinstall just to be sure?

  • 1
    Just out of curiosity...why would you not do a clean install of the production version over the beta? – Allan Oct 9 '17 at 13:36
  • To save some time basically. As I said, I've had some bad experience with beta os on mac before. Last time I tried I then reinstalled down to RTM version of previous version only to find that my time machine backup from then had been deleted, all I was left with was a time machine backup that had been taken from the time the beta was installed and after rolling that in the system was unstable. I had to do a full reinstall of everything including software and data and configuration. – Lasse Vågsæther Karlsen Oct 11 '17 at 12:54

You must log in to answer this question.

Browse other questions tagged .