15

I have discovered an annoying lag when typing on my Mac. It’s a fraction of a second, but it’s enough that it can be as much as a word behind.

The lag occurs when I use Firefox, Notes or Atom, so it is clearly not related to a single application.

I have recently upgraded to 10.13 High Sierra, as well as the supplementary update. I am running on a current model iMac.

As far as I am aware, I’m not running anything in the background which affects the keyboard. I even have background spelling turned off. And, of course, I have restarted.

This is not apparent on my MacBook which is similarly configured.

1
  • When you say lag - does it appear that several characters get "swallowed" in a buffer and as long as you don't type - they stay ready to display on screen and the next letter typed, all the letters pop in place out of the buffer?
    – bmike
    Apr 19 at 11:39
7

The first thing I would try is starting your iMac in Safe Mode as follows:

  1. Fully shut down your iMac
  2. Restart your iMac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. do you still notice the lag)
  6. Exit Safe Mode by restarting your iMac as normal
  7. Test again to see if the lag still persists

Once you've tried the above let me know if the lag was still noticeable in Safe Mode and also when booted in normally again.

5
  • 1
    Thanks for your suggestion. I did restart in Safe Mode, and the issue went away. (I did notice that my preferred text font, Source Code Pro was not available …?). I then restarted normally, and many of the applications didn’t start automatically, which is no loss. Typing is now OK, so it may be one of the unstarted applications or it may be Safe Mode did the trick, for some reason. After some more testing I will report back.
    – Manngo
    Oct 9 '17 at 3:35
  • So far so good. Do you think that just starting in Safe Mode could have solved the problem?
    – Manngo
    Oct 9 '17 at 8:05
  • Yes, it is possible. Starting in Safe Mode does a number of things, two of which impact your Mac even after you've booted normally, namely that the system deletes a whole heap of caches and verifies/repairs your drive's directory.
    – Monomeeth
    Oct 9 '17 at 8:12
  • Hmm, this didn't make any difference for me. Jan 9 '18 at 23:29
  • Safe mode did not fix the issue for me. Actually made it MUCH worse while in Safe mode, entire machine started lagging something awful.
    – o01
    Dec 24 '20 at 0:46
5

Try disabling Automatic graphics switching under battery settings. Seems to have fixed it for me.

4
  • 1
    Wow. This seems to have fixed the lag.
    – Adam
    Feb 27 at 22:36
  • I noticed a weird lag with my new MacBook when typing in vscode. I did also have some weird lag when scrolling in Chrome. Disabling Automatic graphics switching fixed both for me.
    – xh3b4sd
    Mar 11 at 12:28
  • 1
    It works for me as well. Thank you!
    – wawka
    May 9 at 17:06
  • This really worked!!!!
    – Himansh
    Sep 16 at 21:09
1

I'll put this as an separate answer, @Manngo comment was pointing me to solution.

In my case, in PhpStorm typing was horribly slow/laggy, after changed IDE font from Source Code Pro to other font, slowness disappeared.

1
  • Cannot thank you enough - it appears the use of Source Code Pro was causing a very slight lag in places like iTerm and my IDE. Was blaming it on my wireless keyboard, this saved me the $$ of purchasing another one!
    – josh-cain
    Jul 13 '20 at 14:53
1

This question is old, but still appears on the google search, so... I just had the same problem, in my case (the person asking the question doesn't specify) I have a magic keyboard connected wireless. Guess what's the problem?

Simply switch the bluetooth off/on on the magic keyboard and the lag will disappear.

It's a very annoying lag, I also thought it was a configuration issue or a program consuming too much memory.

0

Check your Activity Monitor. Look for processes that have a high CPU usage.

In my case, the lag was caused by a VS Code process which used over 90% of the CPU. As soon as I quit VS Code, the lag stopped.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .