I need to remap "Select the previous input source" shortcut in macOS High Sierra 10.13.

I recently installed fresh macOS High Sierra removing my previous OS and I found that there is no option to change default shortcut from Ctrl+Space to something else.

I used to use macOS Sierra and I managed to set this shortcut to Cmd ⌘+Space. I didn't use any third party software for changing it, however I don't remember how exactly I changed it.

Is there any way to reset it to some custom shortcut? Ideally I'd remap it to Caps Lock which is never used in practice, but Cmd ⌘+Space would also be fine.

UPDATE: After some research I found that it is already possible to remap switching to and from ABC to Caps Lock. There is an option in System Preferences > Keyboard > Input Sources:

enter image description here

But the question is still open since this allows only to switch to and from ABC, but having three input sources you are not able to switch to the third one.

  • Note that the Caps Lock feature only works to and from a non-Latin input source and the last used Latin input source. It cannot be used to switch between two input sources that both use the Latin script. – Tom Gewecke Oct 8 '17 at 17:49
  • @TomGewecke fortunately I have latin source and two non-latin sources that are used less frequently. – Oleksandr Shpota Oct 8 '17 at 18:32
  • Can't understand why the question was downvoted. Is the solution obvious? Is it already answered, or trivial to find? – Oleksandr Shpota Oct 8 '17 at 18:35
up vote 2 down vote accepted

Go to System Preferences > Keyboard > Shortcuts > Input Sources:

System Preferences opened to the location Keyboard > Shortcuts > Input Sources

Then double-click the shortcut listed to the right and enter your preference.


References:
macOS Sierra: Use global keyboard shortcuts (Published Date: Mar 28, 2017)
Mac keyboard shortcuts (Published Date: Jun 11, 2017)
OS X El Capitan: Use input sources to type in other languages (Published Date: Sep 15, 2017)
macOS Sierra: If a keyboard shortcut doesn’t work (Published Date: Mar 28, 2017)

  • Thank you, this works just perfect. The shortcut didn't look clickable/editable at the first glance – Oleksandr Shpota Oct 8 '17 at 17:04
  • You can't select Ctrl key! – Green Jun 15 at 10:43

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.