10

I have a Mid 2011 iMac currently running MacOS 10.12 Sierra. It’s not my main machine, but I would like to install 10.13 on it.

Updating starts smoothly enough, but when it comes to restarting, I get the following message:

macOS could not be installed on your computer An error occurred while verifying firmware.

I understand that my Mac is on the edge, but I read that any machine which supports 10.12 will also support 10.13

The iMac is running from an external SSD, due to a problem with the logic board, so I know that I have some problems. The iMac no longer boots from the internal drive (or recognises the DVD), but still works otherwise.

However, the problems don’t seem to be invove the actual firmware, and the iMac is happily running 10.12.

What does this message mean, and can it be resolved?

  • You'll need to define "a problem with the logic board" as that could be the cause of the error – Steve Chambers Oct 8 '17 at 14:00
  • @SteveChambers Done. The iMac will not boot from the internal drive, and I had the SSD, which replaced the original HD, removed and mounted in an external USB enclosure. – Manngo Oct 8 '17 at 21:06
  • So if I understand correctly if you plug a compatible drive into the internal SATA port on your Mac it is not recognized? This means that one ore more components on your system board are "fried." Depending on what they are they may prevent the firmware from verifying. And verifying Mac firmware on a regular basis is a new feature of High Sierra. So you may be stuck on 10.12 – Steve Chambers Oct 8 '17 at 21:22
7
+50

Apple has introduced a new file system APFS in High Sierra. The easy fix is to verify your backup and then erase the volume and run the installer against a blank / erased main storage drive.

Because the APFS requires support from a new version firmware, your mac's firmware will have to be updated to the latest version during the installation of High Sierra.

After the first restart, the installer prepares the latest version firmware which suitable for your mac model onto EFI system partition of your main disk with bless command. Then restart automatically and trigger the firmware upgrade process. (marked as point A)

After the upgrade process (regardless success or fail), the installer continues. It double checks the version of firmware to make sure it was updated successfully in previous process (namely point A). As a result, the installer find out that your firmware is NOT a latest version still. Hence, it reports "An error occurred while verifying firmware". Yes, it is what you saw on the screen.

The root cause of the failure at point A, in your case, is no internal drive in main bay. The firmware upgrade process only recognize the ESP (EFI System Partition) of primary internal drive. That means the upgrade process was interrupted.

So, you might have to get the primary SATA port work and connect your disk to it. It's said that, most of time, it is the hard drive cable which is out of order, instead of the chipset. If that is the case, it probably can be fixed within $20 to get a replacement. And that was my case. :)

  • 1
    Great answer. Note, the firmware updates are rolled into macOS and don’t really require APFS or HFS+ the timing here is coincidental and not causal from all the research and experience I have. – bmike Aug 19 '18 at 18:19
  • If OP can't fix the primary SATA port and upgrade firmware, I wonder if he/she could use the Clover bootloader instead. – Wowfunhappy Aug 24 '18 at 15:25
5

I had the same issue trying to install High Sierra on my late 2011 MacBook Pro, in which I'd replaced its mechanical HDD with an SSD. The fix was to download the latest version of the High Sierra installer from the App Store and run that - it is version 13.1.05 at the time of writing. Make sure you delete any existing installer you might have first.

This version ran without issue first time, updating the computer's firmware and installing High Sierra.

According to anecdotal comments online, it seems that Apple is installing a firmware upgrade and older versions of the High Sierra installer only worked with specific drive configurations. In my case, I expect the firmware checker was expecting a HDD in this machine when it's now an SSD.

  • This seems to make sense. In my case I'm using the latest installer but I also have nonstandard drive setup. I fixed up a discarded MacBook Air missing its SSD which was too expensive to replace so it boots off an external USB 3 hard drive. It still fails at the verifying firmware stage. – hippietrail Nov 18 '17 at 22:50
  • This is going to be the new “did you reset permissions and reset PRAM/NVRAM” for macOS. Downloading the latest installer from the Mac App Store and running the installer while connected to the internet will do all sorts of good things, including checking the disk, queuing firmware updates that are needed, archive and install the core system and then running the migration script. +a_lot_of_votes – bmike Aug 19 '18 at 18:18
3

Had the same problem on a MacBook Pro 17” (Mid-2010). Turns out it was the aftermarket SSD I had installed pretty much as soon as I bought it. Luckily I kept the original hard drive around, and after trying the newest installer and rebooting into safe mode several times without any joy, I just took a screwdriver and put the old HDD back in temporarily (there are good guides on ifixit.com). The installation with the original HDD completed without any problems, including the firmware update. Afterward, I put the SSD back in and installed Hugh Sierra without any problems - as the firmware update had already been completed, there no longer seemed to be the system check that had tripped me up previously.

Many thanks for your helpful answers. Incidentally, I also have a late 2009 iMac where the original hard drive has been swapped out (drive failure - not even the same manufacturer) and an SSD occupies the optical drive bay. In contrast to my MacBook Pro, the update finished without problems on the iMac. That fits with the issue being related to the primary SATA port.

2

I am getting the impressions that the problem with the logic board is causing this error.

I finally decided to take advantage of the fact the the main drive is external and to plug it into my newer iMac. From there, I could boot from the external drive and install High Sierra successfully.

It didn’t go perfectly smoothly. When the Mac wants to restart as part of the installation, I had to convince to boot again from the external drive, which wasn’t as reliable as I had hoped. I also have an additional partition as a backup, which complicated things. I then had to convince the new Mac to boot from the correct internal partition when I finished.

Nevertheless, I could then plug my external drive back into the old Mac, and it’s been working fine since then. I has even successfully installed minor updates since then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .