2

I have a mid 2013 Macbook Air.

Without realizing the effect of my actions, I accidentally typed into my terminal a sudo -rm -rf "Xcode" command, where I intended to delete Xcode but in actuality deleted all files that contained anything to do with Xcode. As a result, my Mac software was corrupted, and I am unable to login to my computer (it goes to login screen, after entering credentials it crashes).

After countless hours with Apple Support, I:

  1. Tried reinstalling Mac OS in normal recovery mode (Command + R) but it doesn't let me because it keeps asking me to enter login info for App Store purchases and never closes that screen.
  2. Then I tried Internet Recovery Mode, which for some reason isn't able to reinstall MacOS because of an Internet issue (although it works in normal recovery mode) and gives the error "Could not connect to Recovery Mode server." I read up on this on Stack Overflow, and it was advised to use an Ethernet cable connection, which I have tried, but it still doesn't work. In the Safari in the Internet Recover Mode, it gives me the error "Localized String not Found".

migrated from stackoverflow.com Oct 8 '17 at 6:06

This question came from our site for professional and enthusiast programmers.

1

Do you have access to another Mac? If so, I'd download the OS installer to that machine, and use it to make a bootable USB stick via the createinstallmedia tool which is inside Contents/Resources in the installer's app bundle. Then, boot your Mac from that USB stick and all should be well.

Alternately, connect your Mac to another Mac via target disk mode and install it from a fully-booted macOS installation that way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .