After updating latest patch on High Sierra 10.13 on a 2012 MacBook Air, I can no longer copy and paste text. I restarted computer, booted into safe mode, tried copy and pasting in various applications like Textedit. If I do 'cut', the text goes away but clipboard in Finder shows it's empty.

Activity Monitor shows pboard and pbs processes exist. I killed it and a new one appears with same problem. The problem happens using keyboard shortcuts as well as using menu. When I do Command-c, The Edit menu blinks blue while I do that. Drag and drop text works fine. Mouse keys are turned off. I don't have virtualbox. I don't have Copied or additional clipboard software installed.

How can I determine what the problem is? This was working fine yesterday.

Update: Copy and paste was fixed by restoring from Time Machine backup. Reapplying the same High Sierra patch worked fine after that.

  • There was an answer that was deleted but seemed useful pointing to How to reset NVRAM on your Mac
    – Hiyo
    Commented Oct 7, 2017 at 7:23
  • I have the same problem, but resetting NVRAM did not help.
    – Frost
    Commented Oct 7, 2017 at 11:29

2 Answers 2


From this Apple Support discussion:

So, to fix a stuck clipboard (pasteboard) problem, you simply need to:

  1. Open your application folder

  2. Open the utilities subfolder

  3. Open the Activity Monitor app

  4. Type “pboard” into the search box at the top right

  5. In the search results below, there should only be one result — a row listing the “pboard” process. Highlight it by clicking on it.

  6. Click the “x” button at the top left of the window which represents ‘quit this process’

Once you’ve done that, OS X will kill the faulty PBoard process and re-establish it with a fresh one automatically. Your clipboard should be back to normal.


Clear system caches, which is done when booting in safe mode; sometimes a corrupt system cache is the cause, and just restarting in safe mode and again restarting normally fixes problems.

  • 1
    I already booted in safe mode and restarted numerous times. Same problem.
    – Hiyo
    Commented Oct 6, 2017 at 19:52
  • You may need to backup your files and reinstall the software. Commented Oct 6, 2017 at 20:14
  • 1
    I’m doing a time machine restore from a couple of days ago. Hopefully that’ll work. As a Windows user for 25 years who recently switched to Mac I really can’t believe I lost copy and paste ability by updating the OS.
    – Hiyo
    Commented Oct 6, 2017 at 21:07
  • It happens when doing updates from time to time. A full restore tends to fix issues like this. Whenever you update regularly you're patching the previous software and adding layers to it. With a fresh install, there are no extra layers from the old software still on the computer. Commented Oct 6, 2017 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .