0

I am playing the game Age of Empires 1 on Mac OS Sierra, running on a 11 inch macbook air connected to a 23-inch Acer monitor with native 1920 x 1080 resolution. The game is for Windows and doesn't have an official Mac version, so I am using a program called "Porting Kit" which appears to be some kind of Wrapper utility for Wine.

The game itself is 1024 x 768, so when I run it, my screen goes into full screen mode, but the 4:3 aspect ratio is stretched all over the screen, so the picture is shorter and fatter than it would be. I would very much prefer to play with black bars on the left side of the screen, so that the picture at least displays in the correct aspect ratio, not stretched.

I found some forum threads where PC users with Nvidia cards had this problem, e.g. the thread here. However, my Macbook air, if I'm not mistaken, has Intel integrated video, so that doesn't apply.

Also, I tried changing the settings in the Mac OS display preferences, and hold Alt/Option while clicking "scaled" which gives a list of resolutions, including 1024x768. However, when I switch to that resolution, Mac OS also stretches. This is strange because I've seen screenshots of others' display preferences resolution list, and they have things like "1024 x 768" and "1024 x 768 (stretched)", e.g. two different versions, which implies the first one is "unstretched". However, my resolution list doesn't have the corresponding "stretched" versions, and unmarked one is stretched though. Strange.

I also tried fiddling around with the hardware controls on my monitor (an Acer G236HL), i.e. the physical buttons near the power button on my monitor. There seems to be an option called "Wide Mode", which is set to "Full", but there seems to be no way to change it, although the interface suggests there are other options besides "Full", but trying to change that option results in nothing happening, e.g. there do not appear to be any other options.

How do I force my monitor to display a full-screen 4:3 picture with black bars on the two sides, rather than stretched? Again, the program I am using, "Porting Kit" by some guy named "Paul the Tall", doesn't appear to have any "play in windowed" mode feature. There appears to be a "AOE rise of rome unofficial HD patch" (also installed via Porting kit) made by yet another person that allows windowed mode, as well as widescreen resolution support. (edit update: for some reason, windowed mode using this patch crashes the game for me, but full screen mode works, and it allows playing the game in 1920 x 1080 resolution, so technically this is fine. However, I was wondering if there is a more general solution to this problem that can work for other full-screen 4:3 stretched games)

0

Right-click the port in your Porting Kit library, press "Wineskin Tools" -> "Launch Wineskin". In the window that opens, press "Screen Options".

Select "Override" instead of "Automatic" in the top, then select "Fullscreen" in the left and choose the "Resolution" that you want to use below.

Also, that port uses Mac Driver, which is incompatible with the configurations above, so uncheck the "Use Mac Driver instead of X11" box. Be warned: the game was tested with Mac Driver and not X11, so it may not work if you disable that box. If it stops working, you can repeat the process and check that box again.

  • I followed these directions exactly, trying both checked and unchecked for "Use Mac Driver instead of X11", but in both cases, the 1024 x 768 screen resolution is still stretched to fill my entire monitor, instead of having the desired black "letterboxes" on the sides. Just to be clear, changing these settings doesn't require me to reinstall the entire game for them to take hold, right? I also tried "Rootless (windowed)" instead of "fullscreen", but the game launched in fullscreen anyways. Are these settings even taking hold? To be clear, I'm making the changes, then Done, Quit, then play. – xdavidliu Oct 6 '17 at 21:29
  • I just want to add that I tried "Rootless (windowed)" combined with (in the same dialog box) the "Virtual Desktop at 1024 x 768 option", along with an unchecked "Use Mac Driver instead X11", which resulted in a nice 1024 x 768 window instead of full screen. While this is totally satisfactory and playable in my particular case and I'm perfectly satisfied leaving it at that, if anyone knows a more general solution that allows black letterboxes on the sides in fullscreen mode for a 4:3 game playing on a 16:9 monitor, feel free to chime in. – xdavidliu Oct 6 '17 at 21:44
  • Mac Driver isn't compatible with most of the other screen options of Wineskin, so it needs to be disabled to use them properly ;) When selecting "Resolution", when you followed what I described, did you tried to select a 4:3 resolution? – vitormm Oct 7 '17 at 18:07
  • Also, "Rootless (windowed)" + "Normal window" is the same behavior of "Automatic" :P – vitormm Oct 7 '17 at 18:10
  • For your first comment, yes, the 1024 x 768 is a 4:3 resolution. For your second comment: for me "Automatic" was the default setting, and it resulted in the stretched full screen I had initially, not the windowed I get from having "Rootless (window) + Virtual Desktop at 1024 x 768". – xdavidliu Oct 8 '17 at 16:08
0

If you have an AMD card with a 2017 software, you will have "AMD Settings" running. Open it (I have an easy accessible shortcut for it), click on the "Display" tab, click to Enable "GPU Scaling", then in "Scaling Mode" select "Preserve Aspect Ratio". That's it!

If later, viceversa, you have an action game that uses a low 4:3 resolution but could be stretched to the whole screen without altering the action or landscape ratio, do as above but in "Scaling Mode" select "Full panel" instead.

[And no, I am not aware of any "old way" of doing the above via a command line: it would be easier, as it could be associated to the game shortcut using a simple script]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .