1

I have a flush-mounted 128GB SD card for my Macbook Pro. Had it for a year, never any problems or issues.

Today, while trying to free up some space on my main drive, I was moving a large directory -- 11GB -- onto the SD card, when I had to leave my office.

So, I closed my laptop, thinking the copy operation would just resume when I opened it back up and the machine woke up from sleep...

...But now it says that the SD card was "not ejected properly" (I never ejected it). And now I can't get it to be recognized, and thus I can't access my data on what I rely on as an extra hard drive.

I tried remounting via the Automator script in this post, but I see no effect. I then tried pulling the card out & putting it back in, but to no avail. Tried running Disk Utility, but it just sat there "spinning" and was basically frozen & unresponsive for 5 minutes.

Help?

  • Please put your answer that reboot worked. It’s always ok to answer your own question! – bmike Oct 6 '17 at 3:00
2

The answer was to simply reboot. After rebooting, the drive auto-mounted, and all data appeared intact.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .