I'm a Windows 10 user, running macOS High Sierra 10.13 via VirtualBox 5.1.28.
I didn't fully understand how to share a folder.
The part that I did understand and did, is:

  1. Devices → Insert Guest Additions CD image...

But then, in macOS, I type in the terminal:

sudo mount -t vboxsf release_builds ~/Downloads/SteamCMD-GUI

And I get the error:

mount: exec /Library/Filesystems/vboxsf.fs/Contents/Resources/mount_vboxsf for /Users/avi12/Downloads/SteamCMD-GUI: No such file or directory

Later, I checked the directory /Library/Filesystems, and found that:

Which means that, there's actually no directory vboxsf.fs, so there would obviously be an error.

The question is then, what part am I missing?

1 Answer 1


There are no guest additions for macOS in VirtualBox. The shared folder feature of VirtualBox won't work here.

You have to configure a share on the host system and access it from inside the guest with one of the common methods:

  1. Finder > Go > Connect to server... cmdK
  2. Terminal: mount -t smbfs //username:password@server/share .../mountpoint
  3. Finder window > sidebar > Shared > choose share >

Some network connection between host and guest is required (e.g NAT or bridged adapter). Using the latter requires to set up an IP-address in macOS in the same network as the host's adapter.

To set up a bridged adapter for a guest (which has to be shut down) do the following:

  1. Choose the VM > Settings > Network > Adapter 1 > Check Enable Network Adapter > Attached to > Bridged Adapter > choose a network interface of the host (usually either Ethernet or Wi-Fi)
  2. Check the IP config of this interface in the host (e.g. IP= Netmask= Gateway= DNS=
  3. Use the same config in the guest but choose a different IP (e.g.
  4. Connect from the guest to the host with cmdK > enter smb:// > enter the credentials
  • In step 2, I typed: mount -t smbfs //avi12:1@server/share ~/Downloads/SteamCMD-GUI. The error output: mount_smbfs: server connection failed: No route to host
    – avi12
    Oct 5, 2017 at 21:30
  • So how do I solve the problem?
    – avi12
    Oct 5, 2017 at 21:42
  • I see now that the network is NAT. Is the IP set by the IPv4 or public IP?
    – avi12
    Oct 5, 2017 at 22:00
  • I thought at first that you meant the network configuration in the macOS settings in VirtualBox. In VirtualBox's Preferences → NAT Networks, the list is empty at this moment.
    – avi12
    Oct 5, 2017 at 22:21
  • @avi12 Both are important!
    – klanomath
    Oct 5, 2017 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .