I would like to connect an display (Dell LCD monitor P2715Q) to a MacBook Pro Late 2016.

When connecting via USB and Mini DisplayPort, the display still says that there is no signal from the computer. I can't insert the CD that came with monitor since this model of MacBook doesn't have an optical drive.

Is it driver issue (and where could I download them) or is it compatability issue?

  • What is the cable or adapter you are using to connect to the display?
    – user71659
    Oct 5, 2017 at 21:29
  • Converter is original from apple
    – Arhci
    Oct 13, 2017 at 12:49
  • That one is for mDP. The second one is for USB - Satechi.
    – Arhci
    Oct 13, 2017 at 12:58
  • You still need to give more details. Give the exact name and model number of the converters. Try this format: "My xx inch touchbar/no Touch Bar late 2016 MBP is plugged into an Apple X to Y adapter..."
    – user71659
    Oct 13, 2017 at 15:41
  • My 15" touch bar late 2016 MBP is plugged into two adapters: 1. mDP to usb C from Apple, 2. USB type A to usb C Satechi (multi-converter). I am trying to connect with display Dell P2715Q.
    – Arhci
    Oct 15, 2017 at 9:04

2 Answers 2


As I suspected, there is no such thing as a mDP to USB-C converter from Apple. You are using the Thunderbolt 2 to Thunderbolt 3 adapter. It does not convert DisplayPort signals, only Thunderbolt.

  • Oh, I asked them to double check that this is the adapter I need. I am no expert so I believed them.. I should probably get different adapter? Which one would you recommend?
    – Arhci
    Oct 15, 2017 at 18:51
  • I've only used HDMI, but buy a USB-C to DisplayPort adapter that has been reported by others to have worked on your model of computer.
    – user71659
    Oct 15, 2017 at 23:12

I helped a user with the exact same monitor last week. Assuming you have the correct cable/adapter, you need to press the MDP button on the side of the display, not the DP button. Once that was done, all started working properly.

  • Hey, thank you for your help. Unfortunately it still doesn't work. The display still claims there is no mDP cable/signal. Do you think cable or converter is bad?
    – Arhci
    Oct 7, 2017 at 18:57
  • Well, it is possible you could have a faulty adapter/cable. It's also possible you're not using the right one. Can you clarify exactly what you're using? In the case of the user I helped, they've used their display for a number of Macs over the past couple of years and it was only the 2017 MBP that had an issue. The adapter from Apple didn't work, so they bought one from Amazon. It wasn't until that didn't work that they came to me and we discovered the MDP and DP button. Does yours have this button? Have you also set your input source correctly, via the display's menu?
    – Monomeeth
    Oct 8, 2017 at 4:52
  • I connected the display via 2 cables which are the ones that came with display. For USB input I have multiconverter from Satechi and for the other original Apple converter for mDP. I tried with input menu and the answer is still the same "no mDP cable".
    – Arhci
    Oct 13, 2017 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .