12

I am doing development work. We have some test equipment that uses a self-generated SSL certificate. When I try to browse to the equipment in our lab, I get an error that "this connection is not private". However, the only 2 options available are "Show details" and "Go Back".

Show details just lets me look at the info on the certificate, which shows all of the expected self-signed details.

There is no way to tell safari to acknowledge the error and continue onwards. At least not obviously. How do I bypass this error and continue onwards? I'm using safari 11, on OS X sierra.

  • 3
    Is your user an admin user on the macOS installation? I've had good luck entering the password to store the untrusted certificate in the keychain and then manually marking it as trusted if Safari doesn't do that automatically as you proceed to view the page. – bmike Oct 5 '17 at 16:06
13

Press "Show details", then press "visit this website" on the botton, and the "visit website" from the pop up.

Note : if you're still getting this issue after installing the cert, try to edit in keychain access app: locate the cert that you just installed and double click to open the cert, expand "Trust" and change "When using this certificate" option to "Always Trust" close it and refresh the page again, it should work.

  • 3
    Holy crap that was obvious. But totally not obvious. The way it was worded I thought "visit this website" would take me to some informational page about how the evil hax0rz are trying to get me. Thanks a lot, I appreciate the dummy check :-) – Matthew Oct 5 '17 at 16:30
  • 3
    I'm having the same issue but when I show details and allow it just goes back to the same page, over & over & over again. Its an local link to my synology NAS. The cert is by letsencypt. Its anything internal so far. – brinkdad Nov 8 '17 at 5:22
  • 1
    Apple has amended this behavior now, and prompts you to authenticate so that it can store the cert in your store as trusted, before allowing you to continue to the site. I don't want to do that. I just want to ignore the warning, and continue. I don't want to clutter up my store with scores of self-signed certs, which I won't recognize or care about. Chrome still allows you to do this. Safari REALLY needs a setting to re-enable this behavior. – David Krider Feb 7 '18 at 13:21
  • "Show Details" does nothing – William Entriken Apr 20 '18 at 9:30
  • @davidkrider private browsing mode will bypass certificate authentication. – ankii May 16 at 15:10
3

For those who are having the issue where the warning page reloads over and over such as @brinkdad, check the details of the certificate from the page, then open Keychain Access and find the certificate and delete it. Refresh the page and proceed to access the website anyway. This should install the correct certificate to allow you to access the website.

  • Just wanted to say, this was the fix for me. I am using minikube and had rebuilt my environment; apparently the old cert was still in my Keychain and caused the infinite loop of 'visit this website' not working. Deleting the minikube cert in Keychain Access then visiting again fixed it for me. – geerlingguy May 8 '18 at 14:55
3

I found that after deleting the certificate, and then first opening a private Safari tab and proceeding worked. After it works on the private Safari tab it should work on the regular tab as well.

  • Tried this and though I could get to the site in private mode, I am still in the @brinkdad loop on non-private tabs. – Matt Hovey Mar 18 '18 at 15:13
  • I tried all keychain hacks mentioned here to no avail, until I tried the Private Mode, then everything worked. Odd but thanks! – Hampden123 Jun 19 '18 at 12:30
2

I tried all the answers here and was still in the infinite loop described by @brinkdad. I finally got it to work by going into Keychain Access, finding the certificate, right-click Get Info, expand Trust, changed the "When using this certificate" selection from "Custom" to "Always Trust".

pve cert trust settings

1

In my experience, Safari works fine, until it starts doing this. I've learned that once it starts, almost no page I visit is 'approved.' I'm not about to handle every page as a troubleshooting process to force Safari to do what it should do, normally.

So I just force quit Safari and relaunch it. Starts working fine, again. I've also noted I did not have this problem until I installed Wipr and some other ad block plugins that I had tried in the same time frame. So I turn Wipr Off when visiting sites I know might trigger the problem, but which did not previous to blockers.

  • This didn't work for me. – Hampden123 Jun 19 '18 at 12:31
  • Typical of Mac OS/App issues: I find that there can be a dozen different versions of the same bug/issue, and as many things that will fix it for one person, but not another. As often as not, none work. – H Michael Sweeney Jun 20 '18 at 21:28
0

From this Apple Discussion:

The issue could be about https vs. http, or similar Transport Layer Security URL. Unless it is your own bookmark (you could use http instead, without the expectation of security), there is little you can do about it. Often it is something the site owner must do to fix it (Revoked certificate/old certificate; Mix of https and http in a single webpage; etc.).

You must log in to answer this question.

protected by Community Jun 5 '18 at 16:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .