7

I have a MacBook Pro with Touch Bar (MacBookPro13,3, 2016 - running 10.12.6 as it's a company laptop and I cannot update) with two monitors plugged in, each using a USB-C port (but using a USB-C to DisplayPort adapter for each). Whenever it wakes from sleep, the screen arrangement of these two monitors will have switched from what I set it as and I have to go into System Preferences and move them back to get my preferred arrangement back. Just to clarify - the cables have not been switched during this time.

I feel like I remember reading about this issue a while ago on the MacBook Pro but cannot find anything about it. Does anyone have a solution?

3

4 Answers 4

1

I have the same problem with my MBP running Mac OS 10.13.1. My non-Apple monitors are plugged into an OWC Thunderbolt 3 Dock using USB-C to Display Port and Thunderbolt to Display Port cables. So far, the only solution I have come up with is to keep my monitors awake. I am using a black screen saver to make the monitors go dark after 10 minutes. While this is not ideal, it does solve the issue of the displays changing places.

1

I've been having this problem too on my Mac mini with two monitors. I have tried everything suggested in every post I've been able to find and none have worked consistently long term. Yesterday I stumbled on a dumb solution that is working just fine. When the Mac wakes and the screens are switched, I click the "Cancel" "X" at the bottom of the screen asking for the passcode. this puts it back in sleep mode. Then I hit the space bar to wake it again and it usually goes back to the original configuration. A couple of times I have had to do this a second or third time to get it to switch but in every case it has been much easier than going through the multiple windows (more now with the latest iOS update) to rearrange them. I still get all the open windows piled up on one screen so it isn't a perfect solution, just an easier hack to try. I hope it works for you.

0

I was having this issue on my Mac Studio, with 3 LG monitors connected via Thunderbolt. Just got off the phone with Apple support. They were able to fix it by putting the computer into safe mode, then rebooting. To get into safe mode on an M1 Mac, hold the power button until you see the "Options" screen, then hold the left shift key and select your HD. Keep the shift key depressed until you see the login screen. We tested after returning to normal mode by repeatedly putting the Mac to sleep. The screens stopped moving around. Hope this works for you!

UPDATE: It's happening again. Worked fine while Apple were on the line with me, walked away for 30 mins and came back to the same problem. Could be that putting it to sleep doesn't cause the issue but when it sleeps by itself it does. Another thing of interest is that I have a Cintiq tablet connected to the HDMI port. That never moves. So Thunderbolt could be a factor. Back on the phone with Apple.

2
  • Procedure Apple Support gave me to get into safe mode on an M1 Mac: shutdown the Mac, hold the power button until you see the "Options" screen. Select the HD and then hold the shift key which will reveal a 'Boot into Safe Mode' option under the HD. Select this. (No need to hold the shift key while it reboots).
    – ghr
    Commented May 11, 2022 at 1:01
  • I haven't had that issue, but I've had others. Sad to say that the people who answer the phone for AppleCare are not any better at searching online for answers than me (retired software engineer). When they run out of ideas I've already found, they contact engineering who, instead of having a solution, has a time-consuming debugging process for me to do without pay.
    – WGroleau
    Commented Jan 7, 2023 at 17:07
-1

On my M1 Mac mini with two monitors, all the windows on the extended display move to the main monitor after sleeping for at least 10 seconds, regardless of which monitor is the main display. I also had long call with Apple support yesterday and it seemed the problem was fixed by changing an HDMI-HDMI connection to HDM-DVI. However, I didn't wait long enough after forcing machine to sleep before waking it up. (It used to work fine on 2009 and 2012 Mac minis with mini display port and HDMI connections).

Booting into Safe Mode did not help. However, sound output is now much louder - one bonus. Probably due to booting into Safe Mode because reconnecting HDMI-HDMI did not reduce the max volume.

I called Apple Support again today and it was suggested I tick 'Displays have separate Spaces' in System Preferences->Mission Control (opposite to the solution to similar problems). This seems to have worked - the machine has been asleep for a number of 'lengthy' periods and has woken up with all windows where I left them.

Update - August 2022: this 'solution' did not last long.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .