1

Every once in a while, my mouse cursor will stop for a second, or move extremely slow, every half minute or so. I recently upgraded to High Sierra, but also noticed this occurring when running Sierra.

The only way to resolve it is to reboot my machine, which is a problem due to the type of work that I do where I need to keep my undo history.

I've tried restarting many of the apps that I use, but the problem persists. I've also looked at the CPU and Memory tabs in the Activity Monitor, but nothing jumps out as being the culprit.

Does anyone have any suggestions as to how to figure out what's causing this so I don't have to reboot to fix it?

All yesterday, my machine worked without any problems. This morning when I started working, I noticed the problem.

Here are my specs:

  • MacBook Pro 15-inch 2016
  • 2.9 GHz Intel Core i7
  • 16 GB Memory
  • Radeon Pro 460 4 GB
  • 3 TB External Thunderbolt 2 drive
  • Dual LG 27" UltraFine 5K IPS LED Montiors (thunderbolt 3)
  • Logitech MX Master (connected using USB receiver -- have used same mouse for years)
  • Have you tested this setup using a wired mouse to remove the Logitech from the equation? – IconDaemon Oct 4 '17 at 18:27
  • @IconDaemon No, but good suggestion. Will give it a try when I get a chance and report back. – Cofey Oct 4 '17 at 18:34
1

I was having this problem working from the MBP TB touchpad. I had increased the cursor size (settings>accessibility>display>) to somewhere around 60 or 65% of the sliding scale. I reset it to around 40%--still big enough to find and see on the LG 5k, and the problem went away. I also turned off "shake to find cursor" at the same time, so either or both changes might have been responsible for fixing the problem.

0

After removing the USB receiver, I connected my Logitech MX Master to my MacBook Pro via Bluetooth and am no longer experiencing issues with the mouse cursor sticking or slowing down.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .