2

I was updating MacBook Pro to High Sierra and it restart few times and suddenly shows black screen with flashing question mark. I tried to restart it several time and same issue. Then I googled and found that, I need to re-select startup disk and I followed the instructions but no luck.

Unfortunately, I didn't backup machine because of space issues so no time machine option. :(

I have 2 partitions, one for OS and one for Data. The Data drive was encrypted and I never encrypted OS drive. First strange thing I notice in startup menu that OS drive is also encrypted. (BTW, it accepted my user account password when I try to mount drive in recovery mode) And Secondly it is currently showing APFS format type, which is I guess a new format (released in High Sierra) so it looks like the High Sierra was installed (maybe partially). Currently, the OS drive format type is APFS whereas the Data drive is Mac Journaled (encrypted)

When I boot while pressing option key, it doesn't show any drives; just Wifi option. :(

Questions:

  • Is there any possibility to fix this?
  • Is there any way to go back to 10.12.3 Sierra? (which I was running)
  • If I need to re-install OS, is there any way to access user folder and move data? (like in windows we can boot and access/move files using CMD)
  • Does this happen because of encryption?

Edit:

  • Model: MacBook Pro 2016 with TouchBar
  • I am a developer and I have more than 6 months of code in Mamp folder so you guys can understand; how important that would be
  • 1
    That's why you should backup your working code on the web as well as somewhere else. :) Can you try going to Recovery mode by holding Cmd+R when starting up until the Apple logo appears as stated in the same article that you linked to under If your Mac doesn't start up? – Edric Oct 4 '17 at 13:32
  • As my mistake indicate, I'm new to all this. And I hope, someone will come up with a solution and I will get back my data. I tried Recovery mode but nothing useful for me because it doesn't show drive in startup disk menu and I don't wanted to reinstall OS. Most likely the problem is with or because of Encryption... – Alena Oct 4 '17 at 14:20
  • Is there an option for Disk Utility in the macOS Utilities window? – Edric Oct 4 '17 at 14:22
  • yes, I was able to mount both drive in disk utility. When I click on Desktop or Downloads it says, Could not be found but the user dir was there and accessible. No item was under application directory. – Alena Oct 4 '17 at 14:25
  • Any good solution to the problem? I have same problem. – Robin Nov 29 '17 at 5:40
1

I had what I think was the same problem. In the end I was able to install High Sierra from the Recovery Disk (booting with command-R), without losing any data.

  • Can you guide me (step-by-step), how can I start from recovery disk? As both drives are locked and when I select restore from time machine option. It asks me to unlock drive first and when I unlock it. The drive go away from the list. – Alena Oct 5 '17 at 0:51
1

I had a very similar issue with an iMac mid 2017. During an update to High Sierra it just went into a reboot cycle, I'm fortunate enough to have access to another Mac so I target disked the iMac todo a backup just incase. I downloaded the Latest macOS via the App Store and created a bootable USB and then booted the iMac from that USB, started the Install wizard and just installed macOS 10.13.3 straight over the damaged OS and It worked, zero data loss and all apps work as they did before the failure. Best of Luck to anyone who encounters this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .