1

After installing High Sierra the Japanese input method has started to behave very oddly:

  1. My keyboard shortcuts to switch input methods all work as expected but...

  2. After switching to Japanese the output is not as expected: Depending on the application I get either:

    a. plain old roman letters, even with 'Live Conversion' activated, and the space bar (normally activating the conversion to kanji) produces a space.

    b. roman letters, then hitting the space bar converts directly to kanji (no intervening kana) and the kanji (not the normal 'candidate' list) appears to the right of the original roman letters (it should replace them) It should also be noted that hitting the space bar (aimed at doing the conversion) produces a 'Japanese' space (U+3000).

  3. Apple Apps that show behaviour (a) are search bars in:

    • Console
    • App Store
    • Activity Monitor
    • Calendar
    • Font Book
    • Pages, Text Edit (main text area)
  4. Apple Apps that show behaviour (b) are:

    • Dictionary (search bar)
    • Safari (Search/Address bar)

All the non-Apple apps I've tried so far are in the (a) 'complete fail' category.

Re-installing the system had no effect. Likewise repairing permissions by running First Aid from Disk Utility.

There is no text replacement software installed, also no anti-virus software.

A new user account created on the same machine does not suffer from this problem.

Perhaps relatedly, my 'Region and Language' preference pane refuses to load and causes the System Preferences app to freeze when clicked. This does produce an error message in the Console, it reads (helpfully!) <private>.

If anybody has any suggestions as to a straightforward solution, or at least a strategy to identify the problem, I would be extremely grateful.

Cheers.

1

The most straightforward solution is to move everything to a working account.

It used to be you could usually fix these kinds of problems by trashing .plists and .cache files in Home/Library of the bad account, but it seems to be less successful and more tedious with the most recent versions of MacOS.

  • Indeed, I started off by binning everything in my Preferences related to keyboard layout and internationalisation, but to no avail. Eventually I decided to gradually move all my stuff over to a new user account, as I was doing so I came across the Google Japanese IME; now it's installed and seems to be working fine. So for the time being, さようなら Kotoeri! – ScoKoBro Oct 13 '17 at 19:45
-2

If Kokonor font is disabled, try to enable it.

  • Kokonor is for typing tibetan script. Hard to imagine how it could affect japanese input. – Tom Gewecke Oct 6 '17 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .