16

Also, I can no longer pause and play using the button on the headphones.

These are the Beats by Dre headphones that are included for students and educators. The quality is great when I plug in the wire connection.

  • Have you torn down the headphones' existing bluetooth settings and recreated it? – IconDaemon Oct 3 '17 at 19:49
  • Yes: forget device, turn off bluetooth, turn back on, re-discover / pair device. No change :( Thanks – Nick Oct 3 '17 at 22:13
38

Facing exactly the same problem, repairing/rebooting won't work.

But after I switched the mic setting back to Internal Microphone the standard audio quality is back. I guess the audio quality is degraded while the mic is active.

enter image description here

| improve this answer | |
  • Yes, I did notice the audio does change when the active input is changed (i.e. when Siri is activated). When I installed the software update, the problem went away for me. – Nick Nov 27 '17 at 20:12
  • 1
    @Nick what software update? I'm still facing this issue in macOS High Sierra 10.13.1 – vk.edward.li Nov 28 '17 at 9:04
  • the one that worked for me was the 10.13.1 update - sorry :/ – Nick Nov 29 '17 at 23:19
  • I was having extremely choppy performance after upgrading to High Sierra on my macbook pro. It was unusable. I stumbled on this article and changed the sound input to internal microphone. I noticed the difference instantly; for the better. I'm running 10.13.1 on a Mid 2012 13" MBP. – William Pool Dec 6 '17 at 17:01
  • This issue seems to have reappeared in 10.13.2. – Joel Teply Jan 18 '18 at 21:33
3

one option is to enter the following command to the terminal

defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" -int 40

The number 40 might not work for you, try working your way up by running the command with 40, 50, 60 etc. and re-connecting your headset after every time running the command. My JayBird BlueBuds X started working normally at 60.

(https://lifehacker.com/fix-your-bluetooth-audio-in-yosemite-with-this-terminal-1670380974)

Another option that has worked for some people is to set the input device to the internal microphone in Audio settings

sound settings

(https://stackoverflow.com/questions/37901761/bluethooth-headphone-music-quality-deteriorates-when-launching-ios-simulator)

| improve this answer | |
  • Thanks, I did try updating the Bluetooth Audio Agent settings. (Other ones as well per this reddit post: reddit.com/r/apple/comments/5rfdj6/…) restarted Bluetooth, restarted the mac, same bad quality. I found the suggestion about selecting the built-in microphone and no change there either. At this point, my guess is there is something bugged up in the High Sierra upgrade that has yet to be fixed. Thanks again – Nick Oct 4 '17 at 16:51
  • 2
    I keep opening this stackoverflow to find your post, so many times your snippet fixed this for me. Wish it was permanent....but it's at least an immediate workaround. Thanks! – Tiago Jan 21 '19 at 17:17
0

I found the instructions in this article useful: How to Enable the Optimal Audio Codec for Your Bluetooth Headphones in macOS

…but while the quality did get better, it was still not quite "there".

In the end, a combination of the article method combined with the answer above from @lighheaded worked best

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .