0

On my Macbook pro I frequently use an external mouse while working. When the option to use the "Swipe Between Pages" gesture is enabled, it also makes horizontal scrolling on my mouse do the same thing.

I like the feature on the trackpad, but not on the mouse. Is there a way to restrict this gesture to certain devices or in some other way turn it off ONLY for the mouse?

Using Sierra 10.12.6 with internal trackpad and Logitech MX Master with "Logitech Options" software.

  • As you're probably already aware, the Swipe between pages gesture is global between devices that have access to that setting and there is no way within System Preferences or other default macOS settings to change that behavior between devices. Short of writing your own app to handle the desired behavior, you'll need to look for a 3rd-party application/utility solution (if one already exists). – user3439894 Oct 3 '17 at 15:15
0

It looks like the solution in this case was to turn down the sensitivity on the side scroll wheel for the mouse. This way you must scroll very quickly before it reads as a swipe.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .