20

Sometimes new messages come in and Mail (on OS X Lion and Mountain Lion) shows them as empty, with "This message has no content" in the preview column. The message is empty in the full message view window.

I'm connected to Exchange 2010 on the backend.

When I open Outlook for Mac I can see the mail, and it's definitely not empty.

When I quit and restart Mail the message appears in its entirety, but the middle Mail column (with the subject/from/snippet in it) still says "This message has no content".

So a Mail restart sort of fixes the problem, but it's quite annoying.

I didn't have this problem pre-Lion with the same Exchange backend.

  • Before you restart, does it appear properly within the message viewer? In other words, does the problem only exist in the message preview? – Timothy Mueller-Harder Feb 8 '12 at 2:13
  • I edited my response to answer your question: Before restart, it does NOT appear properly in the message viewer. The preview window just says "This message has no content", and the full message view window is empty. – svec Feb 9 '12 at 13:38
  • Is "Display remote images in HTML messages" ticked, in Preferences > Viewing? This probably won't affect it, but it doesn't hurt to try. – Timothy Mueller-Harder Feb 9 '12 at 22:33
  • No, but the messages I've had this problem with don't have any images in them. – svec Feb 10 '12 at 14:18
  • That decreases the likelihood of this working even more, but there's still a chance... – Timothy Mueller-Harder Feb 10 '12 at 21:38
13

I don't know why this happens either, but did I find a workaround that's a bit more lightweight than restarting Mail.app:

Delete the message, and hit CMD-Z (undo delete) immediately after that. This brings back the message, including its lost content.

  • 1
    A horrible solution, but I can confirm that it solves the problem. :) – Henrik Oct 8 '12 at 11:34
  • 2
    this permanently deleted the message, and now it's nowhere to be found. beware! :) – djibouti33 Feb 28 '13 at 6:32
5

This is a sync issue that periodically affects exchange clients (Outlook included from time to time). It is particularly prevalent if you have large numbers of messages in your inbox (rather than in sub-folders).

The quick fix is to drag the message to a local folder, the mail will generally display correctly at that point. If it is dragged back to the exchange folders it will remain displayed since the message is now correctly stored in the local cache.

2

I just had a user with a similar problem in Yosemite. She could read the original message, but once she moved into a new folder on the IMAP email server, she couldn't see anything other than the header info.

Turns out the folder had a semi-colon in its name. Once I changed it to a dash, all the messages appeared correctly.

1

In my case: Select the message; Choose from menu View > Message > 'Raw Source'. Now close the 'Source window'. Select that message again. Contents appear now.

1

I can confirm in MacOS Sierra 10.12.6 this issue still exists. I am getting undeliverable mail messages from GMAIL for my newsletter sign up. On my gmail account I can see the MIME encapsulated content. In the mail.app I only get a "This message has no content" message.

However, when viewing Raw Source as the above comment says, the display window will now show the content of the email, but the 4-line snippet still says "This message has no content".

I also get these kinds of issues for my Google Groups post approval/rejection emails from Google.

Since both of these are auto-generated emails I get from Google, I suspect Google is either not conforming to an email rule or Apple is not conforming to an email rule.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .