0

I back my iPhone up to my Mac. Since I don't have much space on my Mac, I moved my iTunes backup folder to an external drive (copy and paste), and then created a symlink from the normal backup folder to the location on the external drive where that particular backup folder is located. I backed my iPhone up, and it seems to change the backup on the external drive (I can tell by looking at the date modified of the files in the backup folder).

Now, there are two problems I've noticed with this. Firstly, when I connect my device and look in iTunes, it says "Latest Backup: Your iPhone has never been backed up to this computer" – even though it has been backed up (although to an external drive). The worse part is that the "Restore Backup..." button is grayed out, not allowing me to restore my iPhone from the backup.

Another thing I should mention is that when I go to iTunes > Preferences > Devices, I don't see my iPhone backup in the list. I was under the impression that symlinks worked on a low enough level such that applications like iTunes would be fooled into thinking they were on the main drive itself. That isn't the case though, apparently.

So, how do I restore my iPhone from my backup (other than perhaps buying a new Mac with a larger internal hard drive)? I hardly have enough space to move the device backup folder over to my main drive, so I'd like to leave that as a last option.

  • I'm not sure how much help there'll be since this is an unusual way to move your iTunes library; typically you'd just use iTunes' build in method. – JMY1000 Oct 3 '17 at 5:19
  • Just to clarify - are you in a situation where you now need to restore from this backup? Or are you just asking for future reference for the next time you need to restore from a backup? – Monomeeth Oct 3 '17 at 5:43
  • @Monomeeth I'm actually asking for future reference, though I need to restore an iPhone from a backup relatively soon. – Skeleton Bow Oct 3 '17 at 6:04
1

I've definitely seen issues with the symlink during the restore process in the past, but usually it happens mid-restore rather than not being allowed to restore at all. However I haven't checked much on this since the latest iTunes update.

If you navigate through the symlink in Finder:

  • Open Finder, and select the "Go" menu at the top of the screen. Hold the Option key and select the "Library" menu option from the Go menu. (On OSX Lion and above, Library will only appear with the Option key held. On some Sierra configurations, Shift + Option may be needed to get the Library menu item to appear.)

  • From Library, navigate to Application Support > MobileSync > Backup.

Are you able to reach your external drive and see the backup(s)?

If so, can you close iTunes and reopen it now and see if they backup(s) show up in Preferences > Devices?

  • Thanks a lot for the reply! When I go to the backup folder and open it, I go to the backup on my hard drive (by inspecting the folder path). So the symlink definitely is working. The restore backup button is disabled, the Latest Backup information tells me I've never backed up to this computer before, and I don't see the backup at all in Preferences > Devices. I even tried pointing to the external backup folder with an alias in my Library Backups folder instead of a system link (although I do believe symlinks work on a lower level). That didn't work, either – Skeleton Bow Oct 3 '17 at 23:40
  • It seems as though I can make backups just fine. I'll connect the phone to my computer, click "Back Up Now," and then simply wait for the backup to be completed. I can tell it's writing data to the disk because iTunes starts writing around 20-30MB/s, and the activity on my external backup disk also goes up approximately that much. Also the date modified times change. However, it seems iTunes can't read from the backup, although it can write to it. – Skeleton Bow Oct 3 '17 at 23:43
  • Ok I just replicated symlinks on Sierra and High Sierra both with the latest iTunes, and both are working for my setup. Can you rename your current main backup (the folder named by your device UDID, change the folder name to anything else) and make a fresh backup and see if that one appears 1) on the external and 2) in iTunes? – Kelly Oct 4 '17 at 21:17
  • All right, I tried making new backups with no luck. However, I did discover something interesting. Let's call the Backup folder (containing the UDID subfolders) my internal Backup folder, and the Backup folder which I copied to the external drive the external Backup folder. What I was trying to do was copying the UDID backup folders from my internal Backup folder to my external drive, and then making symlinks individually for each UDID backup folder, which targeted the external UDID backup folders, but whose link paths were in my internal Backup folder. – Skeleton Bow Oct 6 '17 at 0:57
  • 1
    Ah that's interesting! I was assuming that you were already symlinking the Backup folder, and not the backups inside. My bad! :) That is definitely interesting though that the individually linked backups don't appear. iTunes probably uses something like stat to see if the individual backup (udid named folder) is a folder, and thinks it isn't because it's a symlink. – Kelly Oct 6 '17 at 16:12
1

I was unable to restore from this backup because I had symlinked the iPhone backup's individual folder,

Volumes/External Drive/iPhone Backups/UF34...

into my Backups folder located at

~/Library/Application Support/MobileSync/Backups/.

This causes some issues. What you need to do is to symlink the backup folder into the MobileSync directory in your user folder. In other words, you need to create a symlink for the folder which contains all your iPhone backups (the folders with the weird numbers),

Volumes/External Drive/iPhone Backups/Backups

inside this folder on your disk

~/Library/Application Support/MobileSync/

I believe you need to rename (or delete) the Backup directory which is already on your hard disk if you want to do this.

I realize that this process might be slightly confusing if one has not used symlinks very often, so feel free to leave a comment here and I will try to make this answer clearer if I can.

  • 1
    thanks for posting this!!! i was looking for an solution to this exact problem... – Joe Feb 16 at 4:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .