0

Pretty simple question, when I press the up arrow to scroll through previous commands, they show up as truncated, even though the terminal is wide enough (and displays output beyond the truncation point):

[2017-10-02 17:38:34,046] WARN Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect (org.apache.zookeeper.ClientCnxn)
java.net.ConnectException: Connection refused
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
    at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717)
    at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:361)
    at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1141)
<er my.zook.com:2181 --list

The last line in that shows the truncated command, which should have been along the lines of ./kafka-topics.sh --zookeeper my.zook.com:2181 --list. Any help getting it to stop truncating would be great. Thanks!

  • 1
    what was the command supposed to be? – Allan Oct 2 '17 at 17:50
  • Updated to show the command – ctote Oct 2 '17 at 18:09
  • What shell are you using? And do you have any shell rc files in your home folder? – fd0 Oct 2 '17 at 18:51
  • I just open terminal, source a .bashrc, which sets some login info for something and sets color options. – ctote Oct 2 '17 at 19:04
  • What terminal type is Terminal set to in Preferences -> Advanced Terminfo? Is this changed in your .bashrc? – Sherwood Botsford Oct 2 '17 at 22:45

You must log in to answer this question.

Browse other questions tagged .