5

I installed Windows 10 on my Mac using Boot Camp Assistant, but later decided to remove the partition as I no longer needed Windows. I did (or tried to) using Boot Camp "restore", but it gave me an error saying it failed. Now when I go into Disk Utility, the Windows partition doesn't appear, so I can't delete it. But it's there somewhere because I'm only showing 180 GB on the Mac partition (not the full 250 GB).

Going back into Boot Camp Assistant doesn't help, it just allows an option to make another partition (no delete or restore option).

I'm at a loss for how to proceed.

enter image description here

  • Our resident expert on these issues is usually in Berlin - but [have a look at this amazing ](apple.stackexchange.com/a/176557/5472) answer and see if you can piece together what partitions to delete and then how to recover / expand your storage. Please back up any data you care to on this system before starting. – bmike Oct 1 '17 at 20:32
  • @bmike I'm still searching for the proper duplicate. Usually the resizeStack command doesn't work after executing a remove Boot Camp in the BC Assistant unsuccessfully. – klanomath Oct 1 '17 at 20:48
2

After an unsuccessful Boot Camp Assistant “Remove Windows 10 or later version” execution, almost any CoreStorage partition I came across was FUBAR. This usually doesn't affect the file system/content of the system volume but some internal CoreStorage structures which inhibits any modification of the Logical Volume Group and subsequent containers.

  • Backup your main macOS volume with Time Machine or another backup solution.
  • Disconnect your external backup drive.

Last resort (very unlikely to work!):

  • Open Terminal and enter diskutil cs list
  • With the UUID of the Logical Volume (usually the last UUID in the output of the previous command) enter

    diskutil cs resizeStack <lvUUID> <size>
    

    e.g.

    diskutil cs resizeStack F95E3156-8CFA-4B73-98F7-5A6D9644CA6F 248500m
    

    The command usually fails with some error. But if you get Error: -69720: There is not enough free space... use a slightly smaller size like 248200m until you are successful.

Common approach (with a Time Machine backup):

  • Restart to Internet Recovery Mode by pressing alt cmd R at startup. Booting to Recovery Mode is not conducive because the Recovery HD will be moved in one of the steps below. And you can't move a partition used as a boot volume.

    The prerequisites are the latest firmware update installed, either E thernet or WLAN (WPA/WPA2) and a router with DHCP activated.
    On a 50 Mbps-line it takes about 4 min (presenting a small animated globe) to boot into a recovery netboot image which usually is loaded from an Apple/Akamai server.

    I recommend Ethernet because it's more reliable. If you are restricted to Wi-Fi and the boot process fails, just restart your Mac with the same shortcut until you succeed booting.

    Alternatively you may start from a bootable installer thumb drive (preferably Sierra) or a thumb drive containing a full system (Sierra).

  • Open Disk Utility in the macOS Utilities window
  • Repartition your internal drive to one volume/GUID partition table/JHFS+.
  • Quit Disk Utility.
  • Attach your backup drive.
  • Open Restore from Time Machine Backup in the macOS Utilities window and restore the backup to your newly created main volume.
  • 1
    Thank you very, very much -- actually your resizeStack method worked nicely without error. – Frank Oct 1 '17 at 22:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .