1

I recently updated to High Sierra, and am now unable to open books (ePubs/PDFs alike) via iBooks. These books are there, I can drag them out to my Desktop or sync them to my iPad, but they do not open in iBooks.

Instead, an alert is displayed with the following text:

The operation couldn’t be completed. (BKAgentServiceErrorDomain error 8.)

A black-HUD-ed spinner appears on the book's icon, spinning indefinitely.

How do I resolve this issue?

  • I am having the same issue, and not sure how to solve it. I refreshed and stopped indexing: sudo mdutil -i off / sudo mdutil -E / Logged out, deauthorised the machine, then logged in and reauthorised: Still same error! This happened since updating to High Sierra. Books are still accessible on iPad – shadi Oct 1 '17 at 20:39
  • There was a recent update to the iBooks app. Did you update? – IconDaemon Oct 13 '17 at 14:56
  • None of my epubs can be opened since high sierra upgrade. The solutions above did not work for me. I hope Apple will remember that iBooks is Apple software, so the issue is clearly with Apple. – Philo Oct 25 '17 at 2:46
1

This is crazy, but it worked (after everything else failed). I opened:

~/Library/Containers/com.apple.BKAgentService/Data/Documents/iBooks/Updates

And clicked on the ePub/PDF files there. iBooks opened them. In my case, I had 1 ePub file, and 1 PDF file. I don't know how or why, but I can confirm that it is an issue related to the Updates folder, because simply deleting that folder caused the problem to resurface.

To all those out there - good luck dealing with this infuriating app.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .