I have been updating the macOS from 10.12.4 to 10.12.6 . For this I have downloaded the macOS dmg file from the Apple website. But when I go on for installing the macOS then I see this error.

Screenshot: Install macOS Sierra Update

I have around 100GB of space but its still not updating the OS. What should I do about it. I need to install "Xcode" from the App Store but when I go on for installing it gives me the error that it needs the OS update to be 10.12.6 How can I fix this up?

The version I am working on is 10.12.4 Screenshot: Mac info


In my experience, downloading and installing the Combo Update sometimes works when the Delta update fails. Please edit your question to indicate the specific Mac model you are working with.

| improve this answer | |
  • Hi, you can check above the version. – shikher.mishra Sep 30 '17 at 19:55
  • I am upgrading el capitan from 10.11 to 10.12 tried combo update still same issues – Ashish Karpe Oct 30 '17 at 9:28
  • @shikher.mishra what did you do ? how did worked for you – Ashish Karpe Oct 30 '17 at 9:29
  • I just did the things mentioned in the above answer. – shikher.mishra Mar 8 '18 at 6:54
  • This answer is in a frustrating state. Ran into the same issue, with combo. Asking this again will be a duplicate despite no solution here? What are the requirements? – LаngLаngС Jul 5 '18 at 18:36

I just bought a reconditioned MacBook Air running macOS High Sierra 10.13.4 and as I wanted to upgrade to macOS High Sierra 10.13.6, I ran into the same problem. I tried everything and was about to give up, until I stumbled the following page:

and realized that FileVault was still encrypting my hard disk and that was blocking any macOS update.

| improve this answer | |
  • Yes! Thank you for this, also your laptop needs to be on adapter power for the encryption to keep running. Thanks! – DJTano Apr 8 at 21:17

Since you have the full installer, I would make a bootable USB installer if you have a spare 8 GB drive lying around.

Search Apple or this site for the createinstallmedia command that you can run from the command line (terminal.app) and make the full installer into a bootable image.

Then restart with the USB and hold option key. This works when your system isn’t bootable at all and much better than just a combo updater or the install app on your main OS.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .