20
  1. When I installed VirtualBox it said that the installation "failed" but I still got VirtualBox.app in my applications folder.
  2. When I try to boot windows 7 VM, it says "Kernel drivers not installed (rc = -1908).
  3. Online solutions are saying I should "restart the host". I checked my StartupItems folder and it's empty.

So I guess the installer failed to install kernel extensions.

So there's this thing called SIP which prevents installing kernel extensions. Should I disable it for now?

What do I do? I need a Windows virtual machine in 8 hours...

37

High Sierra comes with a new security feature: Secure Kernel Extension Loading, which blocks kernel extension loading. The implementation appears to be questionable.

To allow the loading of some non-Apple kernel extension you have to either allow execution in Preferences > Security & Privacy > General:

enter image description here

or disable the security feature with a Terminal command (not recommended):

sudo spctl --master-disable
  • 1
    Thanks heaps.. the button didn't do it.. each time I ran the install it asked me to unlock the same developer. The command did. – baash05 Nov 4 '17 at 10:46
  • 2
    This suggested solution does not work for me (neither "Allow" nor the Terminal command). Has this been tested with VB 5.2 ? – Viking Nov 18 '17 at 13:19
  • 2
    Once it fails once, then it can't be re-installed. High Sierra 10.13.3, VB 5.2.6 & 5.1.4. Uninstalling doesn't help. – gamut Feb 12 '18 at 3:55
  • I'm on 10.13.4 and this unfortunately doesn't work. Allow doesn't do anything, neither does running the command and selecting Anywhere. Nothing under the sun seems to work. – Cornelius May 13 '18 at 18:58
  • I saw a quick note in one of the messages here or in another thread and it was the critical piece I was missing. When I had the Security & Privacy dialog open, the Apply button visible and clicking on the button and there was no apparent action. The prompt still remained. I needed to WAIT longer before trying the Apply. I found I waited 20 minutes until the button actually worked (the prompt went away). – Kevin Buchs Aug 10 '18 at 15:37
6

The solution worked for me on High Sierra. Trick was to do one install run that will definitely fail, but give you the prompt on the General Security tab to Allow Oracle Extensions. Click the Allow option. Then re-run the install again, should result in a successful install.

  • The first answer is the root cause of the issue. However, I feel, this answer is perfect. when you get the failed message after installation and you still see the virtual box, you need to reinstall until it become success as Motifsky stated. Then it should work. It worked for me. Thanks – Karpak Sep 18 '18 at 6:11

You must log in to answer this question.

protected by Community Dec 4 '17 at 17:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .