1

Recently when I visited itunes.apple.com page for some app, Chrome asked me if I would allow opening the product in App Store. I chose "Yes" and I made a stupid mistake of allowing it permanently:

Remember my choice for links of type App Store.app

Now everytime I visit some iTunes page, App Store app automatically pops up and it's really annoying. Is there I way to turn this behaviour off?

I tried searching in Google Chrome settings, but without success (chrome://settings/handlers should obviously list these protocols and programs, but my list is empty).

1

I have found the solution in this comment. The protocol handler in question is macappstores and it needs to be removed from Chrome's list of allowed protocols.

Unfortunately, it is not possible to solve it through UI, so manually editing of Chrome settings file is needed:

  1. Ensure Chrome is closed.
  2. Open a Finder window and use the menu option GoGo to Folder…
  3. In the dialog that pops up paste in the path ~/Library/Application Support/Google/Chrome/ and click the Go button.
  4. Now assuming you don't use profiles in Chrome you want to look for a folder called Default.
    • If you use profiles you will be looking for one probably titled Profile X where X is a number (if there are several of them, you must manually identify yours or perform steps below in each).
    • If you are logged in to Chrome with your Google account, your folder will be probably called Default, too (this was at least my experience).
  5. In that folder you're looking for a file titled Preferences.
  6. Open it in your preferred text editor (TextEdit is enough).
  7. Search for the following text: "macappstores":false. The surrounding text should look similar to this (without newlines and indentation; I have added them just to prettify the text):

    "protocol_handler": {
      "excluded_schemes": {
        …
        "javascript":true,
        "macappstores":false,
        "view-source":true,
        …
      }
    }
    
  8. Delete text "macappstores":false, (note to also delete one comma!) and save file.

  9. Done. Next time you visit itunes.apple.com page with Chrome, you will be asked for permission to open App Store once again.
  • Sort of addendum, before I found the right answer, I was trying to solve it with some apps for editing protocols registered in system. I have found two (RCDefaultApp and SwiftDefaultApps). Both of them are basically very nifty panels for Preferences app, but the first was only able to read (not edit) my protocols and the second one has right now some bugged build available for download and I couldn't open it. Anyway, just adding those here for reference. – FurloSK Sep 30 '17 at 18:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .