1

This used to be default behaviour for iCal (as with most other applications): you click the red button to close the open window but it will still run. A small dot remains under its symbol to show that this is the case. iCal could then pop-up notifications. For a while now, iCal closes when I hit the red button. There is no point under its icon in the dock.

How can I keep iCal running without having to minimise it -and live with an open window in the dock-, to get notifications of my events?

I checked and my preferences have Events set to notify me 10 minutes before. iCal is set to start at login. I'm running Sierra 10.12.6

0

You don't need iCal or Calendar to be open at all anymore. Open System Preferences and select Notifications. Then be sure to review Calendar settings and any Do Not Disturb settings.

enter image description here

Here is the Sierra article on how to use the notification center:

You might put the Calendar at the top and remove any widgets you don't care for so they do not clutter up notifications.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .