8

After upgrading Mac OS X to high sierra, SMB connections started returning authentication error. If I use it on other computer (using el capitan), it smb connection works fine with my username and password. Was wondering if anyone else has faced similar issue.

  • I've just upgraded my Macbook Pro to High Sierra and now can't reach any shared folders/volumes via SMB from my desktop Mac. The other way round - accessing folders/volumes on the desktop from the High Sierra laptop - works fine. – Graham Oct 7 '17 at 16:15
  • If I turn on AFP networking on the laptop I can then log in to the HFS+ volumes mounted on the laptop form the desktop, but not the APFS volume (which is expected behaviour). With only SMB networking turned on I can't access anything. – Graham Oct 7 '17 at 16:20
  • Did you disable client signing (/etc/nbsm.conf on the server)? This seems to be the issue – Allan Oct 19 '17 at 12:42
  • 1
    Found this because I'm having the same issue. There seem to be changes to SMB in 10.13 that are poorly documented. I found a KB article from Apple about SMB in High Sierra, and tried all three tweaks, to no avail. support.apple.com/en-us/HT208209 – user260467 Nov 29 '17 at 0:24
1

My experience is 10.13.4 broke things.

I have 2 macs, the iMac is running 10.13.3 and logs into the freenas server just fine. The mini was running 10.13.3 and then upgraded to 10.13.4 and it will not login to the freenas server on my normal share.

Needless to say I have switched off all OS upgrades on the machine running 10.13.3. I can login to the Freenas from the mini if I use the guest account but I'd rather not use that.

  • I recently upgraded from 10.12.6 to 10.13.4 and it works fine for me. I removed my accepted answer just in case. – dhruvvyas90 Apr 15 '18 at 23:32
0

This is not longer an issue with Mac OS X 10.13.4.

  • I am on 10.14.4 and still have the issue – Ewoks Apr 26 at 7:11
0

Yes, I was and am having similar issues.

I have a MacBookPro (macOS 10.13.6) trying to access file shares on a MacMini (also 10.13.6). With SMB file sharing turned on, in Sharing Preferences on the MacMini (with or without AFP sharing on), double-clicking the MacMini from the Finder on the MacBookPro produces a "Connecting... Not Connected" message, and all attempts to "Connect As" fail. If I turn SMB file sharing off, and AFP file sharing on, I connect fine: either manually, or automatically with my user name and password in the MacBookPro keychain.

I have had this issue before macOS High Sierra, starting with perhaps 10.10 or 10.11. I just turned off SMB sharing, and AFP worked fine. Starting around then, the time to connect to the MacMini increased significantly (30+ seconds). I could never isolate or fix the slow connecting problem. In the past, I have had some luck connecting with my Apple ID instead of as a Registered User, but that doesn't seem to be working now.

I am continuing to look for a solution to the problem, but you are not alone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .