1

I have a strange behavior with a 3 monitor setup, 2 days ago everything was ok, then one monitor stop working and all monitors disapear from display arrangement tab. I have juste updated to High Sierra to see if it can solve anything but no.

All monitor are correctly found by system.

But I cannot access the screen on the right anymore, it's on, it shows a desktop but I cannot use it anymore. Mouse can't go to this space.

enter image description here

This is what is logged when I plug the third monitor :

Sep 29 15:52:17 MacBook-Pro-de-Pierre com.apple.xpc.launchd[1] 
(com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 1952344006, flags: 1
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 1952344006, flags: 1
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 69733568, flags: 1
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 1952344005, flags: 1
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 4128829, flags: 1
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 69733568, flags: 1
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 1952344005, flags: 1
Sep 29 15:52:18 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 4128829, flags: 1
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 1952344005, flags: 4378
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 4128829, flags: 4368
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 1952344006, flags: 4098
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: ReconfigureDisplayCallback displayID: 69733568, flags: 4096
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 1952344005, flags: 4378
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 4128829, flags: 4368
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 1952344006, flags: 4098
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer[321]: ReconfigureDisplayCallback displayID: 69733568, flags: 4096
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: DisplayReconfigurationFinished
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: Display found: Color LCD (1440x900) main: 1 / openGL: 0 / active: 1 / sleep: 0 / builtin: 1 / HiDPI: 1 / displayID: 69733568
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: Display found: BenQ GL2460 (1920x1080) main: 0 / openGL: 0 / active: 1 / sleep: 0 / builtin: 0 / HiDPI: 0 / displayID: 1952344005
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer_Desktop[324]: Display found: BenQ GL2460 (1920x1080) main: 0 / openGL: 0 / active: 1 / sleep: 0 / builtin: 0 / HiDPI: 0 / displayID: 1952344006
Sep 29 15:52:19 MacBook-Pro-de-Pierre TeamViewer[321]: DisplayReconfigurationFinished
Sep 29 15:52:20 MacBook-Pro-de-Pierre TeamViewer[321]: Display found: LCD couleur (1440x900) main: 1 / openGL: 0 / active: 1 / sleep: 0 / builtin: 1 / HiDPI: 1 / displayID: 69733568
Sep 29 15:52:20 MacBook-Pro-de-Pierre TeamViewer[321]: Display found: BenQ GL2460 (1920x1080) main: 0 / openGL: 0 / active: 1 / sleep: 0 / builtin: 0 / HiDPI: 0 / displayID: 1952344005
Sep 29 15:52:20 MacBook-Pro-de-Pierre TeamViewer[321]: Display found: BenQ GL2460 (1920x1080) main: 0 / openGL: 0 / active: 1 / sleep: 0 / builtin: 0 / HiDPI: 0 / displayID: 1952344006
Sep 29 15:52:27 MacBook-Pro-de-Pierre com.apple.xpc.launchd[1] (com.apple.preference.displays.MirrorDisplays): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

Then I uninstall teamviewver, but still have the same problem.

Note : I have reseted NVRAM, SMC and deleted WindowServer prefs.

Any idea ?

2 Answers 2

3

After checked content of Carlo's script, I ran it and it worked like a charm. Many thx.

To complete the answer as asked by JMY2000, this is what the script does :

#!/bin/sh

echo ""
sudo echo "Reset Display Settings v. 1.0.0"
echo ""


echo "Deleting global preferences"
sudo rm -f /Library/Preferences/com.apple.windowserver.plist
sudo rm -f /Library/Preferences/com.apple.windowserver.plist.*
sudo rm -f /Library/Preferences/com.displaylink.plist
sudo rm -f /Library/Preferences/com.displaylink.plist.*
sudo rm -f /Library/Preferences/.GlobalPreferences.plist
sudo rm -f /Library/Preferences/.GlobalPreferences.plist.*
sudo rm -f /private/var/db/.com.apple.iokit.graphics
sudo rm -f /private/var/db/.com.apple.iokit.graphics.*
echo ""

echo "Deleting user preferences"
for i in ~root /Users/*
do
echo $i
sudo rm -f $i/Library/Preferences/com.displaylink.USBNivoListener.plist
sudo rm -f $i/Library/Preferences/ByHost/com.apple.windowserver.*.plist
sudo rm -f $i/Library/Preferences/ByHost/com.apple.windowserver.*.plist.*
sudo rm -f $i/Library/Preferences/.GlobalPreferences.plist
sudo rm -f $i/Library/Preferences/.GlobalPreferences.plist.*
sudo rm -rf $i/Library/Preferences/Caches
done
echo ""

echo "Resetting NVRAM"
sudo nvram -c
echo ""

echo "Done! Please restart the system"

Many thx again.

2
  • While this didn't help my exact problem (GPU issues) it did clear out all the settings which I'm sure have accumulated over a number of years and brought everything back to their defaults. As my problem persisted (frame buffer corruption), I'm more certain now that it's not software related. Thanks.
    – ioquatix
    Oct 29, 2017 at 5:59
  • Warning: I ran this script, and though it fixed my display issues, it appears to have rendered some applications un-launchable. See apple.stackexchange.com/q/308466/84240 Dec 9, 2017 at 13:05
0

We have a script to delete layout persistence: http://www.displaylink.com/downloads/file?d=145 . It may help as even one file can create issues.

Carlo

1
  • 1
    Link-only answers tend to not to be very useful, as resources often get taken down or need better explanation. Could you add the file here?
    – JMY1000
    Oct 2, 2017 at 15:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .