One of the first things that I tried to do when I got my new MacBook Air out of the box was upgrade iTunes to 10.5 (through Software Update). It downloaded the files (four different updates in total), verified data, then started to write the files, at which point it stopped and said that it couldn’t complete the update.

Since then I’ve also downloaded the .dmg file for the iTunes upgrade and for the Lion 10.7.2 combo. My .dmgs can't be verified though; I get an invalid checksum error. I’ve downloaded them a bunch of times too just in case they were corrupted.

Then thinking that because it’s a new machine, I can just refresh the OS and start again, I tried the cmd+r boot and tried to just reinstall and it said:

Can’t install the additional components needed to install Mac OS X.

  • 1
    Just a thought - please check the time and date are set correctly.
    – stuffe
    Commented Dec 4, 2013 at 11:56
  • Try creating a install USB and completely reinstall from that. Commented Jul 5, 2014 at 16:56

2 Answers 2


This is an ancient question (bumped by Community♦), but invalid checksum doesn't have anything to do with admin privileges, it is a bad download.

Since you tried multiple times you are either not getting the file despite the multiple tries, or the original file you are downloading is not complete.

I would look for another way to get the update.


Have you tried checking if you are an admin user of the system? Did you set an admin password when you first booted the system?

You can check this by opening the Terminal app (press Cmd+Space to call Spotlight and type "Terminal" there or go to Applications -> Utilities -> Terminal) and enter

sudo ls

You will be asked for a password. Enter the password for your user.

If it doesn't give an error message, you are the admin of the system and the error could be something else (go to Apple Store asap, you can get a LOT of help from them in resolving such issues).

If it gives you an error, that could just be the root cause of your problem. Open the System Preferences app and go to Users and Groups under the System section. There, select your user and tick the "Allow user to administer this computer" option and restart/log out and log back in.

This should resolve your problem. Else call/email/go to the Apple Store and get their help (for free).

Silly note- When I read just the question, I thought you are a tech admin and are having a problem in your organization as an MBA grad who is using a Mac is not able to install updates on his machine! :)

  • I am definitely the admin, (but not an MBA grad, unfortunately :) ) and I've even tried to make a second user account with admin privileges and it can't update either.
    – pete
    Commented Nov 3, 2011 at 5:27
  • Thanks for your quick reply though!
    – pete
    Commented Nov 3, 2011 at 5:28
  • 1
    Ah well, wait for someone more experienced or hit the Apple Store first thing in the morning... Commented Nov 3, 2011 at 6:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .