When I submit a transaction using Apple Pay, all of my notification e-mails go to the wrong address (one of mine, but not the correct one).

On iOS, the relevant setting (Settings > Wallet & Apple Pay > Transaction Defaults) already has the correct e-mail address, but it's not used. I've also added the correct details within the Apple Pay payment screen but that isn't used or even remembered for subsequent purchases either.

How do I select a different address for use with Apple Pay?

  • Is your Apple ID part of a developer account or other service that has legal contracts associated? (Editing the title since people still are answering for the details the vendor receives instead of getting Apple to change how it emails you)
    – bmike
    Nov 29, 2020 at 10:05
  • @bmike I’m talking about both. They should be the same.
    – orome
    Nov 29, 2020 at 13:53

5 Answers 5


From the Apple Pay Support page:

Update your billing and contact information

Learn how to update your billing and shipping information for the cards that you use with Apple Pay.

iPhone or iPad

  • To change your billing information, go to Settings > Wallet & Apple Pay, tap a card, then tap what you want to update.
  • To update your email address, phone number, and shipping address, go to Settings > Wallet & Apple Pay, then choose what you want to update.
  • I should have mentioned: I'd already tried both of those. The former doesn't really have a place to enter an e-mail address; the latter already has the correct e-mail address, but it's not used.
    – orome
    Sep 28, 2017 at 16:09
  • Please edit your question to include these important facts. It is very helpful to know what you have tried already. You might want to try removing all the Credit & Debit cards from the Wallet and start over.
    – IconDaemon
    Sep 28, 2017 at 16:11
  • "You might want to try removing all the Credit & Debit cards from the Wallet and start over" That was already done quite recently (during a phone replacement). It didn't fix the problem.
    – orome
    Sep 28, 2017 at 16:13
  • +1 I've added some details and this looks like a call or ticket with support would be needed if you've already exhausted the things you can change on your end @orome
    – bmike
    Dec 6, 2017 at 22:51
  • @bmike I’d prefer a different solution. Speaking to the nice folks at Apple has NEVER helped (and often makes things worse) and always takes far too much time.
    – orome
    Dec 6, 2017 at 22:54

In iOS 13.7, there is a TRANSACTION DEFAULTS section of the Settings > Wallet & Apple Pay menu that allows the user to specify default card, shipping address, phone and email for Apple Pay transactions.


If you are asking about making a transaction on your mac via Apple Pay, I discovered today that my mac (OS X 10.15.7) caches my email, shipping and other addresses independently with my Apple ID.

This apple support article gave me some clues: https://support.apple.com/en-mide/guide/mac-help/mchl29cac995/10.15/mac/10.15

Go into System Preferences, click the Apple ID icon top right, on its screen click Payment and Shipping in the left sidebar, where you see Apple card click the little button Details... then (after entering your password) you should see the cached billing address. Mine was all wrong, and I cannot change it there.

The text on that dialog/popup says "On an iOS device running iOS 12.2 or later, you can change the payment method for your Apple ID in Settings. On a Mac or PC, use the Mac App Store or iTunes." (Hey apple, iTunes doesn't exist anymore.)

So I logged in to appleid.app.com. In the Payment & Shipping section (scroll down to see it), I see an Edit button. I click it, then I finally my billing address, and it's invalid. But I cannot edit that address. This is a SNAFU.

Finally on my phone, in Settings -> Apple ID -> Payment & Shipping, I simply removed the Apple Card as a payment option. Then went down to the billing address section and suddenly it was editable! Why was it locked when the Apple Card was there? I cannot explain it.


It looks like the email address in wallet & Pay settings pulls from your contact card, not just what you input in wallet & Pay settings. Try adding the email that you want to use into your contact card before you select it in wallet & Pay settings and see if that helps it stick.

  • The email is in the contact card already.
    – orome
    Dec 13, 2017 at 22:40

In iOS 16.4.1, the trick is to go open Wallet. From there you will see an Email option - expand that and check off the email address you want to use.

Be aware that this setting only applies to the device you've set it on. If it's not set in every Wallet, it won't work as doesn't seem to carry over.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .