6

My Mac Pro (late 2013, cylinder), doesn't want to wake from sleep. I have not a clue what is going on (worked all fine with Sierra).

Anybody?

Config:

  • MacPro 2013 (MacPro6,1) + 2x EIZO EV2450 (both via display-port)
  • Energy Settings: everything unchecked
  • Turn display of after 5 minutes

What I noticed:

  • Screens are in standby/sleep
  • I can hear the fan (still spinning)
  • Power button (on the back) is pulsating (yet fan is not silent?)

What I did:

  • Press power-button for 5 seconds
  • Start and try to zap PRAM
  • Shutdown
  • Pulled power cable for 15 seconds
  • Plug cable (wait 5 seconds)
  • Start Mac.

update:

check your power-management settings:

// terminal
pmset -g live

My settings are (and seem to work for now):

 standby              1
 Sleep On Power Button 1
 womp                 0
 autorestart          0
 hibernatefile        /var/vm/sleepimage
 powernap             0
 gpuswitch            2
 networkoversleep     0
 disksleep            10
 sleep                5 (sleep prevented by sharingd)
 autopoweroffdelay    28800
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         5
 standbydelay         10800

update 2:

For those running into these issues. Two more things you could try.

  • connect your keyboard (if you use usb wired) direct to your mac. Not via a hub or monitor
  • connect each monitor with a usb cable to your mac (this could trigger the wake event)
  • same problem happening to me, should be a High sierra bug – suprandr Sep 29 '17 at 4:12
  • There are bugs and bugs. This is pretty severe! Anyway, I did reset again (PRAM) and switched off/on my monitors (FWIW). For the moment is seems to work. Weird! – Roger Sep 29 '17 at 9:35
  • I have been struggling with this problem ever since the high sierra upgrade. pram reset works for a little while, maybe a few days, then it happens again. I have changed the hibernate mode to 0 3 25, turned off powernap, turned off automatic backups, updated all my software, removed software that I thought may be suspicious, updated to 10.13.1. so far i haven't been able to fix it. it has been referred to as the sleep of death. the system is crashing while it is asleep. i have to press the power button to turn it back on and after it boots up all my programs have to be restored from a hard cra – Chad Nov 4 '17 at 12:13
  • @chad did you compare your pmset settings with mine? For me it worked ever since. Also, might be worth to connect your monitor(s) with a USB cable. – Roger Nov 5 '17 at 11:19
  • Same thing happening for me! It never wakes up. Anybody got an answer to prevent this? I've done all updates on softwares and hardwares. Currently running under OS 10.13.1. – Stephane Nov 12 '17 at 22:30
2
sudo pmset -a hibernatemode 0 

fixed the problem in my case.

  • Hey great! pmset -g live shows all! I have it already set to 0, maybe after reset? – Roger Sep 29 '17 at 20:55
  • it seems to have fixed the problem for a while, but now it's there again.. weird – suprandr Sep 30 '17 at 12:17
  • "pmset -g live" same values as me? – Roger Sep 30 '17 at 15:55
  • yes. To be fair, the problem seems to be at least diminished in some way with that setting – suprandr Sep 30 '17 at 21:42
  • hmmmm, having the same issue now on my pro... Super annoying... Either I see the power button pulsating, but I can't turn it back on, even pressing the power button (or adding new USB devices, or using the keyboard etc). Or the screens stays off, the mac isn't really to sleep, I can ssh into it and reboot it (though the reboot never actually occurs it hangs somehwere on the way) – jyavenard Nov 8 '17 at 18:48
0

Changing pmset didn't fix it for me...

However, this morning upgrade to 10.13.1 (17B48) seems to have prevented the problem somehow. That is, the Mac no longer goes to sleep anymore, but it least it can wake up.

You must log in to answer this question.

protected by Community Nov 13 '17 at 1:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .