2

I have been having a nightmare since I decided to update to High Sierra. High Sierra was failing to install on my HD disk prompting me with the error discussed here (https://forums.developer.apple.com/thread/87690)

I managed to install the OS on a pen drive and boot from there, then, after creating a backup of my files I converted my HD disk to APFS using disk utility and restarted my computer with cmd + R

When starting the installation High Sierra installer asks me for my drive password in order to mount it and begin the installation. I set the password and it proceeds.

The problem comes after it finishes downloading and it reboots. I am presented with a screen asking me for my disk password. I enter the same password I use in order to mount my disk but it keeps rejecting it. I am SURE I am typing the password correctly, with no caps, or spaces.

My concern is if the password being asked is the same password I use to unencrypt my disk and mount it. I am not sure how to proceed now. Pretty frustrating week trying to install High Sierra.

Any tip in the right direction will be appreciated.

EDIT: I found this link (https://forums.developer.apple.com/thread/80174) with a solution to some people. In my case, it fails because there I have no /var/db/dslocal/nodes/Default directory... All I see on my original drive is /var/db/PreviousSystemFiles.plist and /var/db/PreviousSystemLogs.cpgz

EDIT 2: Warning, if you go for the option above, make sure to backup your /users/ folder. In some tests I made I found out that after doing the above, High Sierra ends up overwriting the whole folder thus losing all data.

  • Do you use a QWERTY keyboard? If not, try typing QWERTY equivalent characters... – ddb Sep 28 '17 at 18:52
  • Hi, yes, I tried that. I even tried the small keyboard icon on the top right corner and selecting different languages. No luck. I am seeing more people facing the same issue reddit.com/r/MacOS/comments/72eice/… This is a mess... – JordanBelf Sep 28 '17 at 19:23
  • If you’ve converted a hard drive to APFS, then you’re probably screwed. High Sierra at present only supports APFS for SSDs. – Mike Scott Sep 29 '17 at 6:57
  • Thanks, @MikeScott, I don't see that in the requirements support.apple.com/kb/SP765?viewlocale=en_US&locale=en_US ... anyway, I just found out, it completely wiped my /users folder, deleting all my information. Since I downloaded it everything has been a nightmare. – JordanBelf Sep 29 '17 at 18:08

You must log in to answer this question.

protected by Community Sep 29 '17 at 7:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .